<!DOCTYPE html>
<html lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.taylorsvilletimes.com/xmlrpc.php" />
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:400" />
<link rel="stylesheet" href="https://www.taylorsvilletimes.com/wp-content/themes/bb-theme/css/bootstrap.min.css" />
<!--[if lt IE 9]>
	<script src="https://www.taylorsvilletimes.com/wp-content/themes/bb-theme/js/html5shiv.js"></script>
	<script src="https://www.taylorsvilletimes.com/wp-content/themes/bb-theme/js/respond.min.js"></script>
<![endif]-->
<title>Shaggy’s Good Buys coming soon to Bethlehem &#8211; The Taylorsville Times</title>
    <script>
      var bwg_admin_ajax = 'https://www.taylorsvilletimes.com/wp-admin/admin-ajax.php?action=shortcode_bwg';
      var bwg_ajax_url = 'https://www.taylorsvilletimes.com/wp-admin/admin-ajax.php?action';
      var bwg_plugin_url = 'https://www.taylorsvilletimes.com/wp-content/plugins/photo-gallery';
      document.addEventListener('DOMContentLoaded', function(){ // Analog of $(document).ready(function(){
        bwg_check_ready = function () {}
        document.onkeyup = function(e){
          if ( e.keyCode == 27 ) {
            bwg_remove_loading_block();
          }
        };
      });

      // Set shortcode popup dimensions.
      function bwg_set_shortcode_popup_dimensions() {
        var H = jQuery(window).height(), W = jQuery(window).width();
        jQuery("#TB_title").hide().first().show();
        // New
        var tbWindow = jQuery('#TB_window');
        if (tbWindow.size()) {
          tbWindow.width(W).height(H);
          jQuery('#TB_iframeContent').width(W).height(H);
          tbWindow.attr('style',
            'top:'+ '0px !important;' +
            'left:' + '0px !important;' +
            'margin-left:' + '0;' +
            'z-index:' + '1000500;' +
            'max-width:' + 'none;' +
            'max-height:' + 'none;' +
            '-moz-transform:' + 'none;' +
            '-webkit-transform:' + 'none'
          );
        }
        // Edit
        var tbWindow = jQuery('.mce-window[aria-label="Photo Gallery"]');
        if (tbWindow.length) {
          // To prevent wp centering window with old sizes.
          setTimeout(function() {
            tbWindow.width(W).height(H);
            tbWindow.css({'top': 0, 'left': 0, 'margin-left': '0', 'z-index': '1000500'});
            tbWindow.find('.mce-window-body').width(W).height(H);
          }, 10);
        }
      }
      // Create loading block.
      function bwg_create_loading_block() {
        jQuery('body').append('<div class="loading_div" style="display:block; width: 100%; height: 100%; opacity: 0.6; position: fixed; background-color: #000000; background-image: url('+ bwg_plugin_url +'/images/spinner.gif); background-position: center; background-repeat: no-repeat; background-size: 50px; z-index: 1001000; top: 0; left: 0;"></div>');
      }
      // Remove loading block.
      function bwg_remove_loading_block() {
        jQuery(".loading_div", window.parent.document).remove();
        jQuery('.loading_div').remove();
      }
	  </script>
    <link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Taylorsville Times &raquo; Feed" href="https://www.taylorsvilletimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Taylorsville Times &raquo; Comments Feed" href="https://www.taylorsvilletimes.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Taylorsville Times &raquo; Shaggy’s Good Buys coming soon to Bethlehem Comments Feed" href="https://www.taylorsvilletimes.com/2020/09/02/shaggys-good-buys-coming-soon-to-bethlehem/feed/" />
<meta property="og:title" content="Shaggy’s Good Buys coming soon to Bethlehem"/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.taylorsvilletimes.com/2020/09/02/shaggys-good-buys-coming-soon-to-bethlehem/"/><meta property="og:site_name" content="The Taylorsville Times"/><meta property="og:image" content="https://www.taylorsvilletimes.com/wp-content/uploads/2020/09/Shaggys-Good-Buys-8-27-2020.jpg"/>		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.taylorsvilletimes.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.18"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='formidable-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/formidable/css/formidableforms.css?ver=910311' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_fonts-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/photo-gallery/css/bwg-fonts/fonts.css?ver=0.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='sumoselect-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/photo-gallery/css/sumoselect.min.css?ver=3.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='mCustomScrollbar-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/photo-gallery/css/jquery.mCustomScrollbar.min.css?ver=2.5.40' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_frontend-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/photo-gallery/css/styles.min.css?ver=2.5.40' type='text/css' media='all' />
<link rel='stylesheet' id='webads-admin-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-admin/public/css/webads-admin-public.css?ver=1.2.9' type='text/css' media='all' />
<link rel='stylesheet' id='webads-adrotate-legacy-widget-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-adrotate-legacy-widget/public/css/webads-adrotate-legacy-widget-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='webads-adrotate-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-adrotate/css/webads-adrotate.css?ver=5.7.02' type='text/css' media='all' />
<link rel='stylesheet' id='webads-church-directory-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-church-directory/public/css/webads-church-directory-public.css?ver=1.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='webads-crosswords-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-crosswords/public/css/webads-crosswords-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='webads-display-ads-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-display-ads/public/css/webads-display-ads-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='webads-elasticpress-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-elasticpress/public/css/webads-elasticpress-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='webads-event-calendar-wd-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-event-calendar-wd/public/css/webads-event-calendar-wd-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='webads-google-analytics-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-google-analytics/public/css/webads-google-analytics-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='webads-htm-classifieds-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-htm-classifieds/public/css/webads-htm-classifieds-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='webads-news-ticker-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-news-ticker/public/css/webads-news-ticker-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='webads-online-edition-v1-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-online-edition-v1/public/css/webads-online-edition-v1-public.css?ver=1.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='webads-paperboy-signup-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-paperboy-signup/public/css/webads-paperboy-signup-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='webads-password-protect-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-password-protect/public/css/webads-password-protect-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='webads-photo-gallery-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-photo-gallery/public/css/webads-photo-gallery-public.css?ver=2.5.40.03' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-polls/polls-css.css?ver=2.72' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 8px;
	line-height: 10px;
	height: 10px;
	background-image: url('https://www.taylorsvilletimes.com/wp-content/plugins/webads-polls/images/default_gradient/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='webads-rss-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-rss/public/css/webads-rss-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='webads-social-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-social/public/css/webads-social-public.css?ver=4.7.18' type='text/css' media='all' />
<link rel='stylesheet' id='webads-syndicated-stories-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-syndicated-stories/public/css/webads-syndicated-stories-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='webads-weather-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/webads-weather-v2/public/css/webads-weather-public.css?ver=2.0.7' type='text/css' media='all' />
<link rel='stylesheet' id='ecwd-popup-style-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/event-calendar-wd/css/ecwd_popup.css?ver=5.1.32_5956d77a2c77a' type='text/css' media='all' />
<link rel='stylesheet' id='ecwd_font-awesome-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/event-calendar-wd/css/font-awesome/font-awesome.css?ver=5.1.32_5956d77a2c77a' type='text/css' media='all' />
<link rel='stylesheet' id='ecwd-public-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/event-calendar-wd/css/style.css?ver=5.1.32_5956d77a2c77a' type='text/css' media='all' />
<link rel='stylesheet' id='sc_form-add_event_public-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/ecwd-frontend-event-management/css/style.css?ver=1.0.13' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/bb-plugin/css/font-awesome.min.css?ver=1.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='mono-social-icons-css'  href='https://www.taylorsvilletimes.com/wp-content/themes/bb-theme/css/mono-social-icons.css?ver=1.4' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-magnificpopup-css'  href='https://www.taylorsvilletimes.com/wp-content/plugins/bb-plugin/css/jquery.magnificpopup.css?ver=1.7.2' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js?ver=2.1.1'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/event-calendar-wd/js/gmap/gmap3.js?ver=5.1.32_5956d77a2c77a'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/event-calendar-wd/js/ecwd_popup.js?ver=5.1.32_5956d77a2c77a'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ecwd = {"ajaxurl":"https:\/\/www.taylorsvilletimes.com\/wp-admin\/admin-ajax.php","ajaxnonce":"044e492ffe","loadingText":"Loading...","event_popup_title_text":"Event Details","plugin_url":"https:\/\/www.taylorsvilletimes.com\/wp-content\/plugins\/event-calendar-wd","gmap_type":"ROADMAP","gmap_redirect":"","gmap_key":"AIzaSyCaa0RtTxnqA-JnjHxBpIGMd3YpYmbJm8g","gmap_style":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/event-calendar-wd/js/scripts.js?ver=5.1.32_5956d77a2c77a'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/photo-gallery/js/jquery.sumoselect.min.js?ver=3.0.3'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/photo-gallery/js/jquery.mobile.min.js?ver=1.3.2'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/photo-gallery/js/jquery.mCustomScrollbar.concat.min.js?ver=2.5.40'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/photo-gallery/js/jquery.fullscreen-0.4.1.min.js?ver=0.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bwg_objectsL10n = {"bwg_field_required":"field is required.","bwg_mail_validation":"This is not a valid email address.","bwg_search_result":"There are no images matching your search.","bwg_select_tag":"Select Tag","bwg_order_by":"Order By","bwg_search":"Search","bwg_show_ecommerce":"Show Ecommerce","bwg_hide_ecommerce":"Hide Ecommerce","bwg_show_comments":"Show Comments","bwg_hide_comments":"Hide Comments","bwg_restore":"Restore","bwg_maximize":"Maximize","bwg_fullscreen":"Fullscreen","bwg_exit_fullscreen":"Exit Fullscreen","bwg_search_tag":"SEARCH...","bwg_tag_no_match":"No tags found","bwg_all_tags_selected":"All tags selected","bwg_tags_selected":"tags selected","play":"Play","pause":"Pause","is_pro":"1","bwg_play":"Play","bwg_pause":"Pause","bwg_hide_info":"Hide info","bwg_show_info":"Show info","bwg_hide_rating":"Hide rating","bwg_show_rating":"Show rating","ok":"Ok","cancel":"Cancel","select_all":"Select all","lazy_load":"0","lazy_loader":"https:\/\/www.taylorsvilletimes.com\/wp-content\/plugins\/photo-gallery\/images\/ajax_loader.png","front_ajax":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/photo-gallery/js/scripts.min.js?ver=2.5.40'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-admin/public/js/webads-admin-public.js?ver=1.2.9'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-adrotate-legacy-widget/public/js/webads-adrotate-legacy-widget-public.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-church-directory/public/js/webads-church-directory-public.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-crosswords/public/js/webads-crosswords-public.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-display-ads/public/js/jquery.sudoSlider.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-elasticpress/public/js/webads-elasticpress-public.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-event-calendar-wd/public/js/webads-event-calendar-wd-public.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-google-analytics/public/js/webads-google-analytics-public.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-htm-classifieds/public/js/webads-htm-classifieds-public.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-news-ticker/public/js/webads-news-ticker-public.js?ver=23'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-online-edition-v1/public/js/webads-online-edition-v1-public.js?ver=1.0.3'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-paperboy-signup/public/js/webads-paperboy-signup-public.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-password-protect/public/js/webads-password-protect-public.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-password-protect/public/js/js.cookie.min.js?ver=4.7.18'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-photo-gallery/public/js/webads-photo-gallery-public.js?ver=2.5.40.03'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-rss/public/js/webads-rss-public.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-social/public/js/webads-social-public.js?ver=0.0.1'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-syndicated-stories/public/js/webads-syndicated-stories-public.js?ver=1.0.1'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-weather-v2/public/js/webads-weather-public.js?ver=2.0.8'></script>
<link rel='https://api.w.org/' href='https://www.taylorsvilletimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.taylorsvilletimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.taylorsvilletimes.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='AUTOMOTIVE' href='https://www.taylorsvilletimes.com/2020/09/02/automotive/' />
<link rel='next' title='Brown reflects on Iowa’s decision to cut men’s gymnastics program' href='https://www.taylorsvilletimes.com/2020/09/03/brown-reflects-on-iowas-decision-to-cut-mens-gymnastics-program/' />
<meta name="generator" content="WordPress 4.7.18" />
<link rel="canonical" href="https://www.taylorsvilletimes.com/2020/09/02/shaggys-good-buys-coming-soon-to-bethlehem/" />
<link rel='shortlink' href='https://www.taylorsvilletimes.com/?p=248509' />
<link rel="alternate" type="application/json+oembed" href="https://www.taylorsvilletimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2020%2F09%2F02%2Fshaggys-good-buys-coming-soon-to-bethlehem%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.taylorsvilletimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2020%2F09%2F02%2Fshaggys-good-buys-coming-soon-to-bethlehem%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>

<!-- This site is using AdRotate v5.8.3 Professional to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:175px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<script type="text/javascript">document.documentElement.className += " js";</script>


<script>
    (function (i, s, o, g, r, a, m) {
      i['GoogleAnalyticsObject'] = r;
      i[r] = i[r] || function () {
          (i[r].q = i[r].q || []).push(arguments)
      }, i[r].l = 1 * new Date();
      a = s.createElement(o),
          m = s.getElementsByTagName(o)[0];
      a.async = 1;
      a.src = g;
      m.parentNode.insertBefore(a, m)
  })
  (window, document, 'script', '//www.google-analytics.com/analytics.js', 'ga');
  ga('create', 'UA-85507137-2', 'auto', {
      'siteSpeedSampleRate': '1'   });
    ga('send', 'pageview');
  </script><link rel="stylesheet" href="https://www.taylorsvilletimes.com/wp-content/uploads/bb-theme/skin-5e1f4f85d46f7.css" />
<style id="fl-theme-custom-css">.widget_execphp {
    font-weight: bold;
    padding-top: 20px;
}</style>
<link rel="stylesheet" href="https://www.taylorsvilletimes.com/wp-content/themes/bb-theme-child/style.css" /></head>

<body data-rsssl=1 class="post-template-default single single-post postid-248509 single-format-standard ecwd-theme-parent-bb-theme ecwd-theme-child-bb-theme-child fl-preset-color01 fl-fixed-width" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div>
	<div class="fl-page-bar">
	<div class="fl-page-bar-container container">
		<div class="fl-page-bar-row row">
			<div class="col-md-8 hidden-sm text-left clearfix">		<div class="breakingNews" id="bn7">
			<div class="bn-title"><h2>Breaking News</h2><span></span></div>
			<ul>
								<li><a href="https://www.taylorsvilletimes.com/2020/09/03/brown-reflects-on-iowas-decision-to-cut-mens-gymnastics-program/">Brown reflects on Iowa’s decision to cut men’s gymnastics program</a></li>
								<li><a href="https://www.taylorsvilletimes.com/2020/09/02/shaggys-good-buys-coming-soon-to-bethlehem/">Shaggy’s Good Buys coming soon to Bethlehem</a></li>
								<li><a href="https://www.taylorsvilletimes.com/2020/09/01/nc-to-enter-covid-phase-2-5-friday/">NC to enter COVID Phase 2.5 Friday</a></li>
								<li><a href="https://www.taylorsvilletimes.com/2020/08/31/third-covid-19-death-reported-in-alexander/">Third COVID-19 death reported in Alexander</a></li>
								<li><a href="https://www.taylorsvilletimes.com/2020/08/31/home-invasion-reported-fri-in-bethlehem-community/">Home invasion reported Fri. in Bethlehem Community</a></li>
								<li><a href="https://www.taylorsvilletimes.com/2020/08/27/home-damaged-in-aug-27-fire/">Home damaged in Aug. 27 fire</a></li>
								<li><a href="https://www.taylorsvilletimes.com/2020/08/26/alexander-receives-lgfcu-excellence-in-innovation-award/">Alexander receives LGFCU Excellence in Innovation Award</a></li>
								<li><a href="https://www.taylorsvilletimes.com/2020/08/26/grant-expansion-bring-behavioral-health-to-alexander-co-health-dept/">Grant, expansion bring Behavioral Health to Alexander Co. Health Dept.</a></li>
								<li><a href="https://www.taylorsvilletimes.com/2020/08/24/ribbon-cutting-held-august-20-at-j-j-garage/">Ribbon cutting held August 20 at J &#038; J Garage</a></li>
								<li><a href="https://www.taylorsvilletimes.com/2020/08/21/board-of-elections-sees-early-increase-in-absentee-by-mail-ballot-requests/">Board of Elections sees early increase in absentee by mail ballot requests</a></li>
				
			</ul>
			<div class="bn-navi">
				<span></span>
				<span></span>
			</div>
	</div>
        
<script>
    (function( $ ) {
        $(window).load(function(e) {

            $("#bn7").breakingNews({
                effect		:"slide-v",
                autoplay	:true,
                timer		:7000,
                color		:'default'
            });

        });

    })( jQuery );
</script>

<div class="fl-page-bar-text fl-page-bar-text-1"></div></div>			<div class="col-md-4 col-sm-12 text-right clearfix"><ul class="fl-page-bar-nav nav navbar-nav menu"><li><a href="https://www.taylorsvilletimes.com">Home</a></li></ul><div class="fl-social-icons"><a href="https://www.facebook.com/taylorsvilletimes" target="_blank" class="fl-icon fl-icon-color-mono fl-icon-facebook fl-icon-facebook-regular"></a><a href="https://twitter.com/Tville_Times" target="_blank" class="fl-icon fl-icon-color-mono fl-icon-twitter fl-icon-twitter-regular"></a><a href="https://instagram.com/taylorsvilletimes" target="_blank" class="fl-icon fl-icon-color-mono fl-icon-instagram fl-icon-instagram-regular"></a><a href="/cdn-cgi/l/email-protection#741a1103073400150d181b0607021d181811001d1911075a171b19" class="fl-icon fl-icon-color-mono fl-icon-email fl-icon-email-regular"></a></div></div>		</div>
	</div>
</div><!-- .fl-page-bar --></div>
<div class="fl-page">
	<header class="fl-page-header fl-page-header-primary fl-page-nav-bottom fl-page-nav-toggle-button" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="fl-page-header-wrap">
		<div class="fl-page-header-container container">
			<div class="fl-page-header-row row">
				<div class="col-md-8 col-sm-8">
					<div class="fl-page-header-logo" itemscope="itemscope" itemtype="http://schema.org/Organization">
						<a href="https://www.taylorsvilletimes.com" itemprop="url"><img class="fl-logo-img" itemscope itemtype="http://schema.org/ImageObject" src="https://www.taylorsvilletimes.com/wp-content/uploads/2016/09/Taylorsville-Times-Banner.jpg" data-retina="" alt="The Taylorsville Times" /><meta itemprop="name" content="The Taylorsville Times" /></a>
					</div>
				</div>
				<div class="col-md-4 col-sm-4">
					<div class="fl-page-header-content">
						<div id="webads_weather_widget-2" class="widget widget_webads_weather_widget pull-right">
        <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
            jQuery(document).ready(function() {
                loadWeather('28681', 'transparent', 'Taylorsville', '28681');
            });
        </script>

        <div id="webads-weather-28681" class="widget widget-webads-weather">
            <a id="webads-weather-28681-link" href="https://www.taylorsvilletimes.com">
                <div class="awe-mini">
                    <div>
                        <div class="col visual">
                            <span id="webads-weather-28681-temperature" class="temperature"></span>
                            <i id="webads-weather-28681-image" class="weather-forecast-icon" style="background-size:contain"></i>
                        </div>
                        <div class="col info">
                            <span id="webads-weather-28681-location" class="location"></span>
                            <span id="webads-weather-28681-conditions" class="forecast"></span>
                        </div>
                    </div>
                </div>
            </a>
        </div>

        <script>
            function loadWeather(zipcode, background, location, instanceid) {
                if (zipcode !== undefined) {
                    var location = String(location);
                    var instanceid = String(instanceid);
                    jQuery.ajax({
                        url: "https://ws.iadsnetwork.com/weather.svc/GetCurrentConditions",
                        data: { "zipcode": zipcode },
                        dataType: "json",
                        type: "GET",
                        contentType: "application/json; charset=utf-8",
                        success: function (data) {
                            if (data.d != null) {
                                var dtCC = data.d;
                                for (i = 0; i < dtCC.length; i++) {
                                    jQuery("#webads-weather-" + instanceid + "-temperature").append(dtCC[i].temperature);
                                    jQuery("#webads-weather-" + instanceid + "-location").append(location);
                                    jQuery("#webads-weather-" + instanceid + "-conditions").append(dtCC[i].conditions);
                                    jQuery("#webads-weather-" + instanceid + "-image").css('background-image', 'url(' + dtCC[i].image + ')');
                                    $link = jQuery("#webads-weather-" + instanceid + "-link").attr("href");
                                    jQuery("#webads-weather-" + instanceid + "-link").attr("href", $link + '/weather/?zipcode=' + dtCC[i].zipcode + '&location=' + encodeURIComponent(location));
                                    jQuery("#webads-weather-" + instanceid).css('background-color', background);
                                }
                            }
                        },
                        error: function (d) {
                            //alert("Error");
                        }
                    });
                }
            }
        </script>

        </div><div id="search-2" class="widget widget_search pull-right"><form method="get" role="search" action="https://www.taylorsvilletimes.com" title="Type and press Enter to search.">
	<input type="text" class="fl-search-input" name="s" class="form-control" value="Search" onfocus="if (this.value == 'Search') { this.value = ''; }" onblur="if (this.value == '') this.value='Search';">
</form></div><div id="execphp-2" class="widget widget_execphp pull-right">			<div class="execphpwidget">September 04, 2020</div>
		</div>					</div>
				</div>
			</div>
		</div>
	</div>
	<div class="fl-page-nav-wrap">
		<div class="fl-page-nav-container container">
			<nav class="fl-page-nav navbar navbar-default" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
				<button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse">
					<span>Menu</span>
				</button>
				<div class="fl-page-nav-collapse collapse navbar-collapse">
					<ul id="menu-main-menu" class="nav navbar-nav menu"><li id="menu-item-1076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-1076"><a href="https://www.taylorsvilletimes.com/">Home</a></li>
<li id="menu-item-246036" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-246036"><a href="#">News/Sports</a>
<ul class="sub-menu">
	<li id="menu-item-24448" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-24448"><a href="https://www.taylorsvilletimes.com/category/breaking-news/">Breaking News</a></li>
	<li id="menu-item-766" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-766"><a href="https://www.taylorsvilletimes.com/category/sports/">Sports</a></li>
</ul>
</li>
<li id="menu-item-43221" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43221"><a href="https://www.taylorsvilletimes.com/obituaries/">Obituaries</a></li>
<li id="menu-item-296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-296"><a href="#">E-Editions</a>
<ul class="sub-menu">
	<li id="menu-item-24389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24389"><a target="_blank" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=ebf2cc70-aaa6-40ab-ac88-1de546069d6d">The Taylorsville Times</a></li>
	<li id="menu-item-24388" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24388"><a target="_blank" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=4b944019-7f68-4c98-beee-fd6f2e06aaaa">The Bethlehem Star</a></li>
	<li id="menu-item-24387" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24387"><a target="_blank" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=fced17f6-97f1-4d30-9c1f-2b478c0f1936">125th Anniversary Edition</a></li>
	<li id="menu-item-42416" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-42416"><a href="#">Archives</a>
	<ul class="sub-menu">
		<li id="menu-item-42417" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42417"><a target="_blank" href="http://1709.newstogo.us/editionviewer/default.aspx?view=archives&#038;Edition=4347a18b-eb96-4d2a-af00-10bd5e75bba0">The Taylorsville Times</a></li>
		<li id="menu-item-42418" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42418"><a target="_blank" href="http://1709.newstogo.us/editionviewer/default.aspx?view=archives&#038;Edition=1bb6cacb-0050-467b-abea-88afc18c2e90">The Bethlehem Star</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-42411" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42411"><a href="https://www.taylorsvilletimes.com/category/legal-notices/">Legal Notices</a></li>
<li id="menu-item-24179" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-24179"><a href="https://www.taylorsvilletimes.com/category/classifieds/">Classifieds</a>
<ul class="sub-menu">
	<li id="menu-item-24180" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24180"><a href="https://www.taylorsvilletimes.com/category/classifieds/automotive/">Automotive</a></li>
	<li id="menu-item-24181" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24181"><a href="https://www.taylorsvilletimes.com/category/classifieds/for-rent/">For Rent</a></li>
	<li id="menu-item-24182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24182"><a href="https://www.taylorsvilletimes.com/category/classifieds/for-sale/">For Sale</a></li>
	<li id="menu-item-24184" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24184"><a href="https://www.taylorsvilletimes.com/category/classifieds/general/">General</a></li>
	<li id="menu-item-24185" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24185"><a href="https://www.taylorsvilletimes.com/category/classifieds/help-wanted/">Help Wanted</a></li>
	<li id="menu-item-24188" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24188"><a href="https://www.taylorsvilletimes.com/category/classifieds/wanted/">Wanted</a></li>
	<li id="menu-item-248432" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-248432"><a href="https://www.taylorsvilletimes.com/category/classifieds/yard-sale/">Yard Sale</a></li>
	<li id="menu-item-24137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24137"><a href="https://www.taylorsvilletimes.com/submit-a-classified/">Submit a Classified</a></li>
</ul>
</li>
<li id="menu-item-23818" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-23818"><a href="#">Weekly Circulars</a>
<ul class="sub-menu">
	<li id="menu-item-23819" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23819"><a target="_blank" href="https://www.foodlion.com/weekly-specials/">Food Lion</a></li>
	<li id="menu-item-248500" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-248500"><a target="_blank" href="https://stores.healthmart.com/peoplesdrugstorepharmacy/stores.aspx">Peoples Drug Store</a></li>
</ul>
</li>
<li id="menu-item-24446" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-24446"><a href="#">Connect</a>
<ul class="sub-menu">
	<li id="menu-item-23828" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23828"><a href="https://www.taylorsvilletimes.com/advertising-rates/">Advertising Rates</a></li>
	<li id="menu-item-23425" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-23425"><a target="_blank" href="http://taylorsvillenc.ors.kwnews.com/">Church Directory</a>
	<ul class="sub-menu">
		<li id="menu-item-23426" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23426"><a target="_blank" href="http://taylorsvillenc.ors.kwnews.com/page">Church of the Week</a></li>
	</ul>
</li>
	<li id="menu-item-289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-289"><a href="https://www.taylorsvilletimes.com/crossword/">Crossword</a></li>
	<li id="menu-item-23434" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23434"><a href="https://www.taylorsvilletimes.com/meet-us-on-social-media/">Social media &#038; Our Podcast</a></li>
	<li id="menu-item-290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-290"><a href="https://www.taylorsvilletimes.com/event-calendar/">Events</a></li>
	<li id="menu-item-293" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-293"><a href="https://www.taylorsvilletimes.com/photos/">Photos</a></li>
	<li id="menu-item-46641" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46641"><a href="https://www.taylorsvilletimes.com/public-forum/">Public Forum</a></li>
	<li id="menu-item-23832" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23832"><a href="https://www.taylorsvilletimes.com/times-history/">Times&#8217; History</a></li>
	<li id="menu-item-23435" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23435"><a href="https://www.taylorsvilletimes.com/where-to-buy-the-times/">Where To Buy The Times</a></li>
</ul>
</li>
<li id="menu-item-244238" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-244238"><a href="https://www.taylorsvilletimes.com/business-service-directory/">Business Directory</a></li>
<li id="menu-item-246558" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-246558"><a href="https://www.taylorsvilletimes.com/2020/03/05/why-i-love-alexander-county-an-essay-series/">&#8220;I Love Alexander&#8221; Essays</a></li>
</ul>				</div>
			</nav>
		</div>
	</div>
</header><!-- .fl-page-header -->	<div class="fl-page-content" itemprop="mainContentOfPage">
        <div class="webads-userbar-wrapper" style="display: none;"><span class="webads-userbar"><span class="webads-userbar-name"></span><span class="fl-sep"> | </span><a href="https://www.taylorsvilletimes.com/wp-admin/admin-post.php?action=webads_logout&webads_logout_nonce=DS9URN7DtQcxre6U"><span>logout</span></a></span></div>        <script>
            $(document).ready(function(){
                if (Cookies.get('webads-auth-1709')) {
                    $(".webads-userbar-wrapper").show();
                    $(".webads-userbar-name").text(decodeURIComponent(Cookies.get('webads-username-1709')));
                } else {
                    $(".webads-userbar-wrapper").hide();
                }
            });
        </script>

		
<div class="container">
	<div class="row">
		
				
		<div class="fl-content fl-content-left col-md-9">
							<article class="fl-post post-248509 post type-post status-publish format-standard has-post-thumbnail hentry category-breaking-news category-news" id="fl-post-248509" itemscope="itemscope"
                                         itemtype="http://schema.org/BlogPosting">

    <header class="fl-post-header">
        <h1 class="fl-post-title" itemprop="headline">
            Shaggy’s Good Buys coming soon to Bethlehem                    </h1>
        <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person">By <a href="https://www.taylorsvilletimes.com/author/editor/" itemprop="url"><span itemprop="name">Editor</span></a></span><span class="fl-sep"> | </span><span class="fl-post-date" itemprop="datePublished" datetime="2020-09-02">September 2, 2020</span><span class="fl-sep"> | </span><span class="fl-comments-popup-link"><a href="https://www.taylorsvilletimes.com/2020/09/02/shaggys-good-buys-coming-soon-to-bethlehem/#respond">0 <i class="fa fa-comment"></i></a></span></div><meta itemprop="image" content="https://www.taylorsvilletimes.com/wp-content/uploads/2020/09/Shaggys-Good-Buys-8-27-2020.jpg"><meta itemprop="interactionCount" content="UserComments:0">    </header><!-- .fl-post-header -->

    
            <div class="fl-post-content clearfix" itemprop="text">
                <div id="attachment_248510" style="width: 1034px" class="wp-caption aligncenter"><img class="size-large wp-image-248510" src="https://www.taylorsvilletimes.com/wp-content/uploads/2020/09/Shaggys-Good-Buys-8-27-2020-1024x567.jpg" alt="" width="1024" height="567" srcset="https://www.taylorsvilletimes.com/wp-content/uploads/2020/09/Shaggys-Good-Buys-8-27-2020-1024x567.jpg 1024w, https://www.taylorsvilletimes.com/wp-content/uploads/2020/09/Shaggys-Good-Buys-8-27-2020-300x166.jpg 300w, https://www.taylorsvilletimes.com/wp-content/uploads/2020/09/Shaggys-Good-Buys-8-27-2020-768x425.jpg 768w, https://www.taylorsvilletimes.com/wp-content/uploads/2020/09/Shaggys-Good-Buys-8-27-2020.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /><p class="wp-caption-text">COMING SOON —Above, from left to right: owners Colin Martin and Ben Medlin plan to open Shaggy’s Good Buys in Bethlehem soon.</p></div>
<p>Shaggy’s Good Buys is coming soon to Bethlehem. The new store will be located in the Bethlehem Village Shopping Center at the corner of NC 127 and Rink Dam Road in the former Fred’s building at 9477 NC Highway 127.</p>
<p>Shaggy’s is a value-focused variety store bringing convenience and affordability back to Bethlehem. Shaggy’s offers a wide range of merchandise, including party supplies, hobby supplies, arts &amp; crafts, home goods, housewares, health &amp; beauty items, toys, candy, office and school supplies, greeting cards, gift cards, outdoor seasonal items, pet supplies, discount grocery, hardware, automotive goods, and more.</p>
<p>Shaggy’s Good Buys is owned by Colin Martin and Ben Medlin who both live in Alexander County and grew up in the Bethlehem community.</p>
<p>“Being natives of this community is a benefit to us and our customers because we are able to focus on the needs of Bethlehem and not what corporate executives think the community needs while managing from hundreds of miles away,” Martin stated.</p>
<p>The duo is excited to bring a variety store to Alexander County, with a focus on customer service.</p>
<p>“If you are looking for an organized, clean, and comfortable shopping experience with a laid-back atmosphere, Shaggy’s is the place for you!” Medlin said. “You won’t have to dig through a pile of junk or search through endless pallets that were just pulled off a truck to find what you need. Shaggy’s merchandise will be well organized by department throughout the store where our team of employees will be ready to assist in any way.”</p>
<p>Shaggy’s is currently completing construction which includes new floors, new counters and fixtures, and a complete makeover of the storefront. Shaggy’s will have two entrances featuring automatic sliding doors for customer convenience.</p>
<p>“With more than 15,000 square feet of shopping space, you can count on Shaggy’s to have what you need without driving 30 minutes and walking two miles around a big box store,” Martin said. “Shaggy’s is dedicated to making your shopping experience as convenient and comfortable as possible!”</p>
<p>Shaggy’s plans to open in October with the date of the grand opening and ribbon cutting to be announced soon. The public will be invited.</p>
<div id="attachment_248511" style="width: 757px" class="wp-caption aligncenter"><img class="size-full wp-image-248511" src="https://www.taylorsvilletimes.com/wp-content/uploads/2020/09/Colin-Martin-and-Ben-Medlin-Shaggys.jpg" alt="" width="747" height="856" srcset="https://www.taylorsvilletimes.com/wp-content/uploads/2020/09/Colin-Martin-and-Ben-Medlin-Shaggys.jpg 747w, https://www.taylorsvilletimes.com/wp-content/uploads/2020/09/Colin-Martin-and-Ben-Medlin-Shaggys-262x300.jpg 262w" sizes="(max-width: 747px) 100vw, 747px" /><p class="wp-caption-text">Owners Colin Martin and Ben Medlin plan to open Shaggy’s Good Buys in Bethlehem soon.</p></div>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.taylorsvilletimes.com/2020/09/02/shaggys-good-buys-coming-soon-to-bethlehem/" data-a2a-title="Shaggy’s Good Buys coming soon to Bethlehem"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2020%2F09%2F02%2Fshaggys-good-buys-coming-soon-to-bethlehem%2F&amp;linkname=Shaggy%E2%80%99s%20Good%20Buys%20coming%20soon%20to%20Bethlehem" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2020%2F09%2F02%2Fshaggys-good-buys-coming-soon-to-bethlehem%2F&amp;linkname=Shaggy%E2%80%99s%20Good%20Buys%20coming%20soon%20to%20Bethlehem" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_printfriendly" href="https://www.addtoany.com/add_to/printfriendly?linkurl=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2020%2F09%2F02%2Fshaggys-good-buys-coming-soon-to-bethlehem%2F&amp;linkname=Shaggy%E2%80%99s%20Good%20Buys%20coming%20soon%20to%20Bethlehem" title="PrintFriendly" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>                </div><!-- .fl-post-content -->

                
        <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags">Posted in <a href="https://www.taylorsvilletimes.com/category/breaking-news/" rel="category tag">Breaking News</a>, <a href="https://www.taylorsvilletimes.com/category/news/" rel="category tag">News</a></div></div>                <div class="fl-comments">

    
    
            <div id="respond">

            <h3 class="fl-comments-respond-title">Leave a Comment</h3>

            
                <form class="fl-comment-form" action="https://www.taylorsvilletimes.com/wp-comments-post.php"
                      method="post">

                                                <label for="author">Name (required)</label>
                            <input type="text" name="author" class="form-control" value=""
                                   tabindex="1" aria-required='true' />
                            <br/>

                            <label for="email">Email (will not be published) (required)</label>
                            <input type="text" name="email" class="form-control"
                                   value=""
                                   tabindex="2" aria-required='true' />
                            <br/>

                            <label for="url">Website</label>
                            <input type="text" name="url" class="form-control"
                                   value="" tabindex="3"/>
                            <br/>

                        
                    <label for="comment">Comment</label>
                    <textarea name="comment" class="form-control" cols="60" rows="8" tabindex="4"></textarea>
                    <br/>

                                        <div class="g-recaptcha" data-sitekey="6LdvRcMZAAAAAEXIplzSR6ZvSkSZTV1inA8BbwkV"></div>
                    <br>


                    <input name="submit" type="submit" class="btn btn-primary" tabindex="5"
                           value="Submit Comment"/>
                    <input type='hidden' name='comment_post_ID' value='248509' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
                    
                    <div class="fl-comment-form-cancel">
                        <a rel="nofollow" id="cancel-comment-reply-link" href="/2020/09/02/shaggys-good-buys-coming-soon-to-bethlehem/#respond" style="display:none;">Click here to cancel reply.</a>                    </div>

                </form>
                    </div>
    
    
</div>

        
                <style>
                    .fl-post-featured-post {
                        border-bottom: 1px solid #e6e6e6;
                        margin-bottom: 10px;
                        padding-bottom: 0px;
                        margin-left: 20px;
                    }

                    .fl-post-featured-image-beside .fl-post-featured-image {
                        float: left;
                        width: 120px;
                        padding-right: 5px;
                    }

                    .fl-clear {
                        clear: both;
                    }

                    h5.fl-post-featured-title {
                        margin: 0 0 10px;
                        padding: 0;
                        font-weight: bold;
                    }

                    .fl-post-featured-image {
                        margin-bottom: 10px;
                    }

                    .fl-post-featured-image img {
                        height: auto !important;
                        width: 100% !important;
                    }

                    .fl-post-featured-header {
                        margin-bottom: 15px;
                    }

                </style>
                <div id="webads-related-posts">
                    <h3>Related Posts</h3>


                    
                        <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image"
                             itemscope="itemscope" itemtype="http://schema.org/BlogPosting">

                                                            <div class="fl-post-featured-image">
                                    <a href="https://www.taylorsvilletimes.com/2020/09/03/brown-reflects-on-iowas-decision-to-cut-mens-gymnastics-program/" rel="bookmark"
                                       title="Brown reflects on Iowa’s decision to cut men’s gymnastics program">
                                        <img width="300" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2020/09/8867cf03-02012020_iowamensgymnasticsvsuicandminn050-300x300.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" itemprop="image" />                                    </a>
                                </div>
                            
                            <div class="fl-post-featured-header">
                                <h5 class="fl-post-featured-title" itemprop="headline">
                                    <a href="https://www.taylorsvilletimes.com/2020/09/03/brown-reflects-on-iowas-decision-to-cut-mens-gymnastics-program/" rel="bookmark"
                                       title="Brown reflects on Iowa’s decision to cut men’s gymnastics program">Brown reflects on Iowa’s decision to cut men’s gymnastics program</a>
                                </h5>
                                <div class="fl-post-featured-meta">
														<span class="fl-post-featured-date">
					September 3, 2020				</span>
                                                                            <span class="fl-sep"> | </span>
                                        <span class="fl-post-featured-comments">
					<a href="https://www.taylorsvilletimes.com/2020/09/03/brown-reflects-on-iowas-decision-to-cut-mens-gymnastics-program/#respond">No Comments »</a></span>
                                                                    </div>
                            </div>


                            <div class="fl-clear"></div>

                        </div>


                        
                        <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image"
                             itemscope="itemscope" itemtype="http://schema.org/BlogPosting">

                                                            <div class="fl-post-featured-image">
                                    <a href="https://www.taylorsvilletimes.com/2020/09/01/nc-to-enter-covid-phase-2-5-friday/" rel="bookmark"
                                       title="NC to enter COVID Phase 2.5 Friday">
                                        <img width="300" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2020/09/Cooper-Covid-9-1-crop-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" itemprop="image" />                                    </a>
                                </div>
                            
                            <div class="fl-post-featured-header">
                                <h5 class="fl-post-featured-title" itemprop="headline">
                                    <a href="https://www.taylorsvilletimes.com/2020/09/01/nc-to-enter-covid-phase-2-5-friday/" rel="bookmark"
                                       title="NC to enter COVID Phase 2.5 Friday">NC to enter COVID Phase 2.5 Friday</a>
                                </h5>
                                <div class="fl-post-featured-meta">
														<span class="fl-post-featured-date">
					September 1, 2020				</span>
                                                                            <span class="fl-sep"> | </span>
                                        <span class="fl-post-featured-comments">
					<a href="https://www.taylorsvilletimes.com/2020/09/01/nc-to-enter-covid-phase-2-5-friday/#respond">No Comments »</a></span>
                                                                    </div>
                            </div>


                            <div class="fl-clear"></div>

                        </div>


                        
                        <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image"
                             itemscope="itemscope" itemtype="http://schema.org/BlogPosting">

                                                            <div class="fl-post-featured-image">
                                    <a href="https://www.taylorsvilletimes.com/2020/08/31/third-covid-19-death-reported-in-alexander/" rel="bookmark"
                                       title="Third COVID-19 death reported in Alexander">
                                        <img width="300" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2020/03/N2004P64042C-sq-1-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" itemprop="image" />                                    </a>
                                </div>
                            
                            <div class="fl-post-featured-header">
                                <h5 class="fl-post-featured-title" itemprop="headline">
                                    <a href="https://www.taylorsvilletimes.com/2020/08/31/third-covid-19-death-reported-in-alexander/" rel="bookmark"
                                       title="Third COVID-19 death reported in Alexander">Third COVID-19 death reported in Alexander</a>
                                </h5>
                                <div class="fl-post-featured-meta">
														<span class="fl-post-featured-date">
					August 31, 2020				</span>
                                                                            <span class="fl-sep"> | </span>
                                        <span class="fl-post-featured-comments">
					<a href="https://www.taylorsvilletimes.com/2020/08/31/third-covid-19-death-reported-in-alexander/#respond">No Comments »</a></span>
                                                                    </div>
                            </div>


                            <div class="fl-clear"></div>

                        </div>


                        
                        <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image"
                             itemscope="itemscope" itemtype="http://schema.org/BlogPosting">

                                                            <div class="fl-post-featured-image">
                                    <a href="https://www.taylorsvilletimes.com/2020/08/31/home-invasion-reported-fri-in-bethlehem-community/" rel="bookmark"
                                       title="Home invasion reported Fri. in Bethlehem Community">
                                        <img width="300" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2020/08/Crime-Alert-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" itemprop="image" />                                    </a>
                                </div>
                            
                            <div class="fl-post-featured-header">
                                <h5 class="fl-post-featured-title" itemprop="headline">
                                    <a href="https://www.taylorsvilletimes.com/2020/08/31/home-invasion-reported-fri-in-bethlehem-community/" rel="bookmark"
                                       title="Home invasion reported Fri. in Bethlehem Community">Home invasion reported Fri. in Bethlehem Community</a>
                                </h5>
                                <div class="fl-post-featured-meta">
														<span class="fl-post-featured-date">
					August 31, 2020				</span>
                                                                            <span class="fl-sep"> | </span>
                                        <span class="fl-post-featured-comments">
					<a href="https://www.taylorsvilletimes.com/2020/08/31/home-invasion-reported-fri-in-bethlehem-community/#respond">No Comments »</a></span>
                                                                    </div>
                            </div>


                            <div class="fl-clear"></div>

                        </div>


                        
                        <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image"
                             itemscope="itemscope" itemtype="http://schema.org/BlogPosting">

                                                            <div class="fl-post-featured-image">
                                    <a href="https://www.taylorsvilletimes.com/2020/08/27/home-damaged-in-aug-27-fire/" rel="bookmark"
                                       title="Home damaged in Aug. 27 fire">
                                        <img width="300" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2020/08/08-27-20-FIRE-IMG_0765-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" itemprop="image" />                                    </a>
                                </div>
                            
                            <div class="fl-post-featured-header">
                                <h5 class="fl-post-featured-title" itemprop="headline">
                                    <a href="https://www.taylorsvilletimes.com/2020/08/27/home-damaged-in-aug-27-fire/" rel="bookmark"
                                       title="Home damaged in Aug. 27 fire">Home damaged in Aug. 27 fire</a>
                                </h5>
                                <div class="fl-post-featured-meta">
														<span class="fl-post-featured-date">
					August 27, 2020				</span>
                                                                            <span class="fl-sep"> | </span>
                                        <span class="fl-post-featured-comments">
					<a href="https://www.taylorsvilletimes.com/2020/08/27/home-damaged-in-aug-27-fire/#respond">No Comments »</a></span>
                                                                    </div>
                            </div>


                            <div class="fl-clear"></div>

                        </div>


                        
                </div>
                </article>
<!-- .fl-post -->					</div>
		
		<div class="fl-sidebar fl-sidebar-right fl-sidebar-display-always col-md-3" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
		<aside id="adrotate_widgets-2" class="fl-widget widget_adrotate_widgets"><div class="g g-1"><div class="g-dyn a-3 c-1"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Adams Funeral Home - Spotlight', 1.00, {'nonInteraction': 1});" href="http://www.adamsfunerals.com" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Adams Funeral Home - Spotlight', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2017/01/Adams-Funeral-BC-2017.jpg" /></a></div><div class="g-dyn a-18 c-2"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Jobs', 1.00, {'nonInteraction': 1});" href="http://www.hometownemploymentnetwork.com/default.aspx?affiliateid=1137" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Jobs', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2016/09/jobs.jpg" /></a></div><div class="g-dyn a-5 c-3"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Hendren Insurance', 1.00, {'nonInteraction': 1});" href="http://www.hendreninsurance.com/" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Hendren Insurance', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2017/01/Hendren-Insurance-BC-2017.jpg" /></a></div><div class="g-dyn a-26 c-4"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Service Directory', 1.00, {'nonInteraction': 1});" href="https://www.taylorsvilletimes.com/business-service-directory/"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Service Directory', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2017/08/Service-Directory-BC-for-web-2017.jpg" /></a></div></div></aside><aside id="adrotate_widgets-3" class="fl-widget widget_adrotate_widgets"><div class="a-single a-10"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Breaking News Signup', 1.00, {'nonInteraction': 1});" href="https://www.taylorsvilletimes.com/breaking-news-signup/"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Breaking News Signup', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2016/10/breakingNewsHeader.png" /></a></div></aside><aside id="polls-widget-2" class="fl-widget widget_polls-widget"><h4 class="fl-widget-title">Online Poll</h4>Thank you for participating in our poll.<ul><li><a href="https://www.taylorsvilletimes.com/pollsarchive">Polls Archive</a></li></ul></aside><aside id="webads_displayads_widget-2" class="fl-widget widget_webads_displayads_widget">

                <style>
                    #displayAds img {
                        width: 100%;
                        height: auto;
                    }

                                        #displayAdsWrapper {
                        height: 1500px;
                        overflow: hidden;
                    }
                    

                </style>

                <div id="displayAdsWrapper">
                    <div id="displayAds">
                        <ul id="displayAdsUL">
                        </ul>
                    </div>
                </div>

                <script>
                    (function( $ ) {
                        $(document).ready(function () {
                            loadDisplayAds(1709, 100, 1);
                        });

                        function loadDisplayAds(memberid, count, thumbtype) {

                            if (memberid !== undefined) {
                                var memberid = String(memberid);
                                var count = String(count);
                                var thumbtype = String(thumbtype);
                                if (memberid.length == 4) {
                                    $.ajax({
                                        url: "https://ws.iadsnetwork.com/displayads.svc/GetDisplayAds",
                                        data: { "memberid": memberid, "count": count, "thumbtype": thumbtype },
                                        dataType: "json",
                                        type: "GET",
                                        contentType: "application/json; charset=utf-8",
                                        success: function (data) {

                                            if (data.d != null) {
                                                $("#displayAdsUL").empty();
                                                var dtDisplayAd = data.d;

                                                for (i = 0; i < dtDisplayAd.length; i++) {
                                                    if (typeof ga !== "undefined") {
                                                        // safe to use the function
                                                        ga('send','event','Adverts','impression',dtDisplayAd[i].name,2,{'nonInteraction':1});
                                                        $("#displayAdsUL").append('<li style="padding-bottom: 5px;"><a onClick="ga(\'send\',\'event\',\'Adverts\',\'click\',\'' + dtDisplayAd[i].name + '\',1,{\'nonInteraction\':1});" href="' + dtDisplayAd[i].url + '" target="_blank"><img src="' + dtDisplayAd[i].img + '" alt=" " /></a></li>');
                                                    } else {
                                                        $("#displayAdsUL").append('<li style="padding-bottom: 5px;"><a href="' + dtDisplayAd[i].url + '" target="_blank"><img src="' + dtDisplayAd[i].img + '" alt=" " /></a></li>');
                                                    }
                                                }
                                                setTimeout(function(){ startSlider(i) }, 1000);
                                            }
                                        },
                                        error: function (d) {
                                            //alert("Error");
                                        }
                                    });
                                } else {
                                    $("#displayAdsWrapper").empty();
                                }
                            }
                        }

                        function startSlider(count) {
                            var isAuto = true;
                            var pauseLen = '5000';

                            $("#displayAds").sudoSlider({
                                vertical: true,
                                continuous: true,
                                                                slideCount: count+1,
                                auto: isAuto,
                                                                autoHeight: false,
                                                                pause:  pauseLen,
                                prevNext: false,
                                autoWidth: true
                            });
                        }
                    })( jQuery );

                </script>

                </aside><aside id="text-2" class="fl-widget widget_text">			<div class="textwidget"><div style="text-align: center"><a href="http://1709.newstogo.us/weeklyspecials/?MemberID=1709" target="_blank"><strong>View All Advertisers</strong></a></div></div>
		</aside>	</div>
		
	</div>
</div>

			
	</div><!-- .fl-page-content -->
				</div><!-- .fl-page -->
		<footer class="fl-page-footer-wrap" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
		<div class="fl-page-footer-widgets">
	<div class="fl-page-footer-widgets-container container">
		<div class="fl-page-footer-widgets-row row">
		<div class="col-sm-4 col-md-4"><aside id="nav_menu-3" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">The Taylorsville Times</h4><div class="menu-footer-menu-1-container"><ul id="menu-footer-menu-1" class="menu"><li id="menu-item-228" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-228"><a href="https://www.taylorsvilletimes.com/">Home</a></li>
<li id="menu-item-229" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-229"><a href="https://www.taylorsvilletimes.com/contact-us/">Contact Us</a></li>
<li id="menu-item-24392" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24392"><a target="_blank" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=ebf2cc70-aaa6-40ab-ac88-1de546069d6d">The Taylorsville Times</a></li>
<li id="menu-item-24391" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24391"><a target="_blank" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=4b944019-7f68-4c98-beee-fd6f2e06aaaa">The Bethlehem Star</a></li>
<li id="menu-item-24390" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24390"><a target="_blank" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=fced17f6-97f1-4d30-9c1f-2b478c0f1936">125th Anniversary Edition</a></li>
<li id="menu-item-231" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-231"><a target="_blank" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=ebf2cc70-aaa6-40ab-ac88-1de546069d6d&#038;view=subscribe">Subscribe</a></li>
<li id="menu-item-23835" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23835"><a href="https://www.taylorsvilletimes.com/copyright/">Copyright</a></li>
<li id="menu-item-23836" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23836"><a href="https://www.taylorsvilletimes.com/times-history/">Times&#8217; History</a></li>
<li id="menu-item-23837" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23837"><a href="https://www.taylorsvilletimes.com/advertising-rates/">Advertising Rates</a></li>
<li id="menu-item-23839" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23839"><a href="https://www.taylorsvilletimes.com/where-to-buy-the-times/">Where To Buy The Times</a></li>
</ul></div></aside></div><div class="col-sm-4 col-md-4"><aside id="webads_syndicated_stories_menu_widget-2" class="fl-widget widget_webads_syndicated_stories_menu_widget"><h4 class="fl-widget-title">US &#038; World News</h4> 
   
   <div><ul class="menu">
   <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/united-states/">US</a></li>
   <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/sports/">Sports</a></li>
   <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/entertainment/">Entertainment</a></li>
   <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/technology/">Technology</a></li>
   <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/political/">Politics</a></li>
   <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/world/">World</a></li>
   <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/business/">Business</a></li>
   <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/health/">Health</a></li>
   </ul></div>   
   
   </aside></div><div class="col-sm-4 col-md-4"><aside id="nav_menu-5" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">Odds &#038; Ends</h4><div class="menu-footer-menu-3-container"><ul id="menu-footer-menu-3" class="menu"><li id="menu-item-216" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-216"><a href="https://www.taylorsvilletimes.com/crossword/">Crossword Puzzle</a></li>
<li id="menu-item-217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-217"><a href="https://www.taylorsvilletimes.com/event-calendar/">Event Calendar</a></li>
<li id="menu-item-1473" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1473"><a href="https://www.taylorsvilletimes.com/poll/">Online Poll</a></li>
<li id="menu-item-218" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218"><a href="https://www.taylorsvilletimes.com/photos/">Photo Galleries</a></li>
<li id="menu-item-23840" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23840"><a href="https://www.taylorsvilletimes.com/meet-us-on-social-media/">Meet us on social media</a></li>
</ul></div></aside></div>		</div>
	</div>
</div><!-- .fl-page-footer-widgets --><div class="fl-page-footer">
	<div class="fl-page-footer-container container">
		<div class="fl-page-footer-row row">
			<div class="col-md-12 text-center clearfix"><div class="fl-page-footer-text fl-page-footer-text-1">This website is powered by <a href="http://www.websitesfornewspapers.com" target="_blank"><i><strong>WebsitesForNewspapers.com</strong></i></a></div></div>					</div>
	</div>
</div><!-- .fl-page-footer -->	</footer>
	
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.dyngroup.js'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?ver=4.7.18'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.taylorsvilletimes.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/webads-polls/polls-js.js?ver=2.72'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/ecwd-frontend-event-management/js/autocomplete.js?ver=1.0.13'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/themes/bb-theme/js/jquery.throttle.min.js?ver=1.4'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/plugins/bb-plugin/js/jquery.magnificpopup.min.js?ver=1.7.2'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-includes/js/comment-reply.min.js?ver=4.7.18'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/themes/bb-theme/js/bootstrap.min.js?ver=1.4'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-content/themes/bb-theme/js/theme.js?ver=1.4'></script>
<script type='text/javascript' src='https://www.taylorsvilletimes.com/wp-includes/js/wp-embed.min.js?ver=4.7.18'></script>
<!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){if(jQuery.fn.gslider) {
	jQuery('.g-1').gslider({groupid:1,speed:6000,repeat_impressions:'Y'});
}});
</script>
<!-- /AdRotate JS -->

</body>
</html>