<!DOCTYPE html> <html lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml"> <head><link rel="dns-prefetch" href="//ajax.googleapis.com">
<link rel="dns-prefetch" href="//www.google.com">
<link rel="dns-prefetch" href="//fonts.googleapis.com">
<link rel="preload" href="https://www.taylorsvilletimes.com/wp-content/cache/borlabs_cache/1/js/d23048877b0d9b68db0a93414a15470648bd3b5b_https.js" as="script">
<link rel="preload" href="https://www.taylorsvilletimes.com/wp-content/cache/borlabs_cache/1/css/30c169d1e8d99505890b27151768b218facd4723_https.css" as="style">
<link rel="stylesheet" href="https://www.taylorsvilletimes.com/wp-content/cache/borlabs_cache/1/css/30c169d1e8d99505890b27151768b218facd4723_https.css" type="text/css" media="all"><link href="https://fonts.googleapis.com/css?family=Oswald%3A400" rel="stylesheet"> <meta charset="UTF-8" /> <meta name="viewport" content="width=device-width, initial-scale=1.0" /> <meta http-equiv="X-UA-Compatible" content="IE=edge" /> <link rel="profile" href="https://gmpg.org/xfn/11" /> <link rel="pingback" href="https://www.taylorsvilletimes.com/xmlrpc.php" />   <!--[if lt IE 9]> <script src="https://www.taylorsvilletimes.com/wp-content/themes/bb-theme/js/html5shiv.js"></script> <script src="https://www.taylorsvilletimes.com/wp-content/themes/bb-theme/js/respond.min.js"></script> <![endif]--> <title>Commissioners propose changing school board election to partisan &#8211; The Taylorsville Times</title>  <link rel='dns-prefetch' href='//ajax.googleapis.com' /> <link rel='dns-prefetch' href='//www.google.com' /> <link rel="alternate" type="application/rss+xml" title="The Taylorsville Times &raquo; Feed" href="https://www.taylorsvilletimes.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="The Taylorsville Times &raquo; Comments Feed" href="https://www.taylorsvilletimes.com/comments/feed/" /> <link rel="alternate" type="application/rss+xml" title="The Taylorsville Times &raquo; Commissioners propose changing school board election to partisan Comments Feed" href="https://www.taylorsvilletimes.com/2021/04/09/commissioners-propose-changing-school-board-election-to-partisan/feed/" /> <meta property="og:title" content="Commissioners propose changing school board election to partisan"/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.taylorsvilletimes.com/2021/04/09/commissioners-propose-changing-school-board-election-to-partisan/"/><meta property="og:site_name" content="The Taylorsville Times"/><meta property="og:image" content="https://www.taylorsvilletimes.com/wp-content/uploads/2018/04/County-Seal-lineart-3x3-color.jpg"/>                      <style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 8px;
	line-height: 10px;
	height: 10px;
	background-image: url('https://www.taylorsvilletimes.com/wp-content/plugins/webads-polls/images/default_gradient/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>                                                   <link rel="https://api.w.org/" href="https://www.taylorsvilletimes.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.taylorsvilletimes.com/wp-json/wp/v2/posts/250790" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.taylorsvilletimes.com/xmlrpc.php?rsd" /> <link rel='prev' title='Volunteers being sought for Litter Sweep' href='https://www.taylorsvilletimes.com/2021/04/09/volunteers-being-sought-for-litter-sweep/' /> <link rel="canonical" href="https://www.taylorsvilletimes.com/2021/04/09/commissioners-propose-changing-school-board-election-to-partisan/" /> <link rel='shortlink' href='https://www.taylorsvilletimes.com/?p=250790' /> <link rel="alternate" type="application/json+oembed" href="https://www.taylorsvilletimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F04%2F09%2Fcommissioners-propose-changing-school-board-election-to-partisan%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://www.taylorsvilletimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F04%2F09%2Fcommissioners-propose-changing-school-board-election-to-partisan%2F&#038;format=xml" />  <style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:175px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>  <link rel="shortcut icon" href="https://www.taylorsvilletimes.com/wp-content/uploads/2021/03/favicon-16x16-1.png"/>  <style id="fl-theme-custom-css">.widget_execphp {
    font-weight: bold;
    padding-top: 20px;
}</style> <script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js?ver=1.12.4' id='jquery-js'></script><script type='text/javascript' src='https://www.google.com/recaptcha/api.js?ver=5.5.3' id='recaptcha-scripts-js'></script><script type="text/javascript" src="https://www.taylorsvilletimes.com/wp-content/cache/borlabs_cache/1/js/d23048877b0d9b68db0a93414a15470648bd3b5b_https.js"></script></head> <body class="post-template-default single single-post postid-250790 single-format-standard ecwd-theme-parent-bb-theme ecwd-theme-child-bb-theme-child fl-preset-color01 fl-fixed-width" itemscope="itemscope" itemtype="http://schema.org/WebPage"> <div> <div class="fl-page-bar"> <div class="fl-page-bar-container container"> <div class="fl-page-bar-row row"> <div class="col-md-8 hidden-sm text-left clearfix"> <div class="breakingNews" id="bn7"> <div class="bn-title"><h2>Breaking News</h2><span></span></div> <ul> <li><a href="https://www.taylorsvilletimes.com/2021/04/09/commissioners-propose-changing-school-board-election-to-partisan/">Commissioners propose changing school board election to partisan</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/04/09/volunteers-being-sought-for-litter-sweep/">Volunteers being sought for Litter Sweep</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/04/07/vaccines-open-to-all-age-16/">Vaccines open to all age 16+</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/04/07/two-people-shot-several-arrested-in-april-6-incident/">Two people shot, several arrested in April 6 incident</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/04/07/fire-death-reported-april-7-in-hiddenite/">Fire, death reported April 7 in Hiddenite</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/03/31/vaccines-open-to-all-essential-workers-group-4-on-mar-31/">Vaccines open to all essential workers, Group 4, on Mar. 31</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/03/31/womens-history-month-and-agricultural-month-feature/">Women’s History Month and Agricultural Month feature</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/03/25/accelerated-timeline-for-vaccination-eligibility-announced/">Accelerated timeline for vaccination eligibility announced</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/03/24/gov-cooper-some-virus-restrictions-relaxed/">Gov. Cooper: some virus restrictions relaxed</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/03/24/jimison-wins-regional-spelling-bee/">Jimison wins Regional Spelling Bee</a></li> </ul> <div class="bn-navi"> <span></span> <span></span> </div> </div>  <div class="fl-page-bar-text fl-page-bar-text-1"></div></div> <div class="col-md-4 col-sm-12 text-right clearfix"><ul class="fl-page-bar-nav nav navbar-nav menu"><li><a href="https://www.taylorsvilletimes.com">Home</a></li></ul><div class="fl-social-icons"><a href="https://www.facebook.com/taylorsvilletimes" target="_blank" class="fl-icon fl-icon-color-mono fl-icon-facebook fl-icon-facebook-regular"></a><a href="https://twitter.com/Tville_Times" target="_blank" class="fl-icon fl-icon-color-mono fl-icon-twitter fl-icon-twitter-regular"></a><a href="https://instagram.com/taylorsvilletimes" target="_blank" class="fl-icon fl-icon-color-mono fl-icon-instagram fl-icon-instagram-regular"></a><a href="/cdn-cgi/l/email-protection#c3ada6b4b083b7a2baafacb1b0b5aaafafa6b7aaaea6b0eda0acae" class="fl-icon fl-icon-color-mono fl-icon-email fl-icon-email-regular"></a></div></div> </div> </div> </div></div> <div class="fl-page"> <header class="fl-page-header fl-page-header-primary fl-page-nav-bottom fl-page-nav-toggle-button" itemscope="itemscope" itemtype="http://schema.org/WPHeader"> <div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="col-md-8 col-sm-8"> <div class="fl-page-header-logo" itemscope="itemscope" itemtype="http://schema.org/Organization"> <a href="https://www.taylorsvilletimes.com" itemprop="url"><img class="fl-logo-img" itemscope itemtype="http://schema.org/ImageObject" src="https://www.taylorsvilletimes.com/wp-content/uploads/2016/09/Taylorsville-Times-Banner.jpg" data-retina="" alt="The Taylorsville Times" /><meta itemprop="name" content="The Taylorsville Times" /></a> </div> </div> <div class="col-md-4 col-sm-4"> <div class="fl-page-header-content"> <div id="webads_weather_widget-2" class="widget widget_webads_weather_widget pull-right">  <div id="webads-weather-28681" class="widget widget-webads-weather"> <a id="webads-weather-28681-link" href="https://www.taylorsvilletimes.com"> <div class="awe-mini"> <div> <div class="col visual"> <span id="webads-weather-28681-temperature" class="temperature"></span> <i id="webads-weather-28681-image" class="weather-forecast-icon" style="background-size:contain"></i> </div> <div class="col info"> <span id="webads-weather-28681-location" class="location"></span> <span id="webads-weather-28681-conditions" class="forecast"></span> </div> </div> </div> </a> </div>  </div><div id="search-2" class="widget widget_search pull-right"><form method="get" role="search" action="https://www.taylorsvilletimes.com" title="Type and press Enter to search."> <input type="text" class="fl-search-input" name="s" class="form-control" value="Search" onfocus="if (this.value == 'Search') { this.value = ''; }" onblur="if (this.value == '') this.value='Search';"> </form></div><div id="execphp-2" class="widget widget_execphp pull-right"> <div class="execphpwidget">April 09, 2021</div> </div> </div> </div> </div> </div> </div> <div class="fl-page-nav-wrap"> <div class="fl-page-nav-container container"> <nav class="fl-page-nav navbar navbar-default" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span>Menu</span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-main-menu" class="nav navbar-nav menu"><li id="menu-item-1076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-has-children menu-item-1076"><a href="https://www.taylorsvilletimes.com/">Home</a> <ul class="sub-menu"> <li id="menu-item-24448" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-24448"><a href="https://www.taylorsvilletimes.com/category/breaking-news/">Breaking News</a></li> <li id="menu-item-766" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-766"><a href="https://www.taylorsvilletimes.com/category/sports/">Sports</a></li> <li id="menu-item-24446" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-24446"><a href="#">Connect</a> <ul class="sub-menu"> <li id="menu-item-23828" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23828"><a href="https://www.taylorsvilletimes.com/advertising-rates/">Advertising Rates</a></li> <li id="menu-item-23425" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-23425"><a target="_blank" rel="noopener noreferrer" href="http://taylorsvillenc.ors.kwnews.com/">Church Directory</a> <ul class="sub-menu"> <li id="menu-item-23426" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23426"><a target="_blank" rel="noopener noreferrer" href="http://taylorsvillenc.ors.kwnews.com/page">Church of the Week</a></li> </ul> </li> <li id="menu-item-289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-289"><a href="https://www.taylorsvilletimes.com/crossword/">Crossword</a></li> <li id="menu-item-23434" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23434"><a href="https://www.taylorsvilletimes.com/meet-us-on-social-media/">Social media &#038; Our Podcast</a></li> <li id="menu-item-290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-290"><a href="https://www.taylorsvilletimes.com/event-calendar/">Events</a></li> <li id="menu-item-293" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-293"><a href="https://www.taylorsvilletimes.com/photos/">Photos</a></li> <li id="menu-item-46641" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46641"><a href="https://www.taylorsvilletimes.com/public-forum/">Public Forum</a></li> <li id="menu-item-23832" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23832"><a href="https://www.taylorsvilletimes.com/times-history/">Times’ History</a></li> <li id="menu-item-23435" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23435"><a href="https://www.taylorsvilletimes.com/where-to-buy-the-times/">Where To Buy The Times</a></li> </ul> </li> </ul> </li> <li id="menu-item-43221" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43221"><a href="https://www.taylorsvilletimes.com/obituaries/">Obituaries</a></li> <li id="menu-item-296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-296"><a href="#">E-Editions</a> <ul class="sub-menu"> <li id="menu-item-24389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24389"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=ebf2cc70-aaa6-40ab-ac88-1de546069d6d">The Taylorsville Times</a></li> <li id="menu-item-24388" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24388"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=4b944019-7f68-4c98-beee-fd6f2e06aaaa">The Bethlehem Star</a></li> <li id="menu-item-246558" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-246558"><a href="https://www.taylorsvilletimes.com/2020/03/05/why-i-love-alexander-county-an-essay-series/">&#8220;I Love Alexander&#8221; Essays</a></li> <li id="menu-item-24387" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24387"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=fced17f6-97f1-4d30-9c1f-2b478c0f1936">125th Anniversary Edition</a></li> <li id="menu-item-42416" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-42416"><a href="#">Archives</a> <ul class="sub-menu"> <li id="menu-item-42417" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42417"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?view=archives&#038;Edition=4347a18b-eb96-4d2a-af00-10bd5e75bba0">The Taylorsville Times</a></li> <li id="menu-item-42418" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42418"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?view=archives&#038;Edition=1bb6cacb-0050-467b-abea-88afc18c2e90">The Bethlehem Star</a></li> </ul> </li> </ul> </li> <li id="menu-item-249508" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249508"><a href="https://www.taylorsvilletimes.com/2021/04/07/legal-notices-2/">LEGAL NOTICES</a></li> <li id="menu-item-24179" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-24179"><a href="https://www.taylorsvilletimes.com/category/classifieds/">Classifieds</a> <ul class="sub-menu"> <li id="menu-item-249509" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249509"><a href="https://www.taylorsvilletimes.com/2021/04/07/automotive/">AUTOMOTIVE</a></li> <li id="menu-item-249510" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249510"><a href="https://www.taylorsvilletimes.com/2021/04/07/for-rent-12/">FOR RENT</a></li> <li id="menu-item-249511" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249511"><a href="https://www.taylorsvilletimes.com/2021/04/07/for-sale-2/">FOR SALE</a></li> <li id="menu-item-249512" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249512"><a href="https://www.taylorsvilletimes.com/2021/04/07/general-4/">GENERAL</a></li> <li id="menu-item-249513" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249513"><a href="https://www.taylorsvilletimes.com/2021/04/07/help-wanted-9/">HELP WANTED</a></li> <li id="menu-item-249514" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249514"><a href="https://www.taylorsvilletimes.com/2021/04/07/wanted/">WANTED</a></li> <li id="menu-item-24137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24137"><a href="https://www.taylorsvilletimes.com/submit-a-classified/">Submit a Classified</a></li> </ul> </li> <li id="menu-item-23818" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-23818"><a href="#">Weekly Circulars</a> <ul class="sub-menu"> <li id="menu-item-23819" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23819"><a target="_blank" rel="noopener noreferrer" href="https://www.foodlion.com/weekly-specials/">Food Lion</a></li> <li id="menu-item-250750" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-250750"><a target="_blank" rel="noopener noreferrer" href="https://www.ollies.us/home.html">Ollie&#8217;s Bargain Outlet</a></li> </ul> </li> <li id="menu-item-244238" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-244238"><a href="https://www.taylorsvilletimes.com/business-service-directory/">Business Directory</a></li> </ul> </div> </nav> </div> </div> </header> <div class="fl-page-content" itemprop="mainContentOfPage"> <div class="webads-userbar-wrapper" style="display: none;"><span class="webads-userbar"><span class="webads-userbar-name"></span><span class="fl-sep"> | </span><a href="https://www.taylorsvilletimes.com/wp-admin/admin-post.php?action=webads_logout&webads_logout_nonce=DS9URN7DtQcxre6U"><span>logout</span></a></span></div>  <div class="container"> <div class="row"> <div class="fl-content fl-content-left col-md-9"> <article class="fl-post post-250790 post type-post status-publish format-standard has-post-thumbnail hentry category-breaking-news category-news" id="fl-post-250790" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <header class="fl-post-header"> <h1 class="fl-post-title" itemprop="headline"> Commissioners propose changing school board election to partisan </h1> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person">By <a href="https://www.taylorsvilletimes.com/author/editor/" itemprop="url"><span itemprop="name">Editor</span></a></span><span class="fl-sep"> | </span><span class="fl-post-date" itemprop="datePublished" datetime="2021-04-09">April 9, 2021</span><span class="fl-sep"> | </span><span class="fl-comments-popup-link"><a href="https://www.taylorsvilletimes.com/2021/04/09/commissioners-propose-changing-school-board-election-to-partisan/#respond">0 <i class="fa fa-comment"></i></a></span></div><meta itemprop="image" content="https://www.taylorsvilletimes.com/wp-content/uploads/2018/04/County-Seal-lineart-3x3-color.jpg"><meta itemprop="interactionCount" content="UserComments:0"> </header> <div class="fl-post-content clearfix" itemprop="text"> <div data-contents="true"> <div class="" data-block="true" data-editor="b4pk1" data-offset-key="bnq73-0-0"> <div class="_1mf _1mj" data-offset-key="bnq73-0-0"><span data-offset-key="bnq73-0-0"> </span></div> </div> <div class="" data-block="true" data-editor="b4pk1" data-offset-key="5r4ud-0-0"> <div class="_1mf _1mj" data-offset-key="5r4ud-0-0"><em>The following notice of Public Hearing was published recently in The Times:</em></div> </div> <div class="" data-block="true" data-editor="b4pk1" data-offset-key="d2mp7-0-0"> <div class="_1mf _1mj" data-offset-key="d2mp7-0-0"><span data-offset-key="d2mp7-0-0"> </span></div> </div> <div class="" data-block="true" data-editor="b4pk1" data-offset-key="5eqea-0-0"> <div class="_1mf _1mj" data-offset-key="8meb-0-0"><span data-offset-key="8meb-0-0">The public will hereby take notice that the Alexander County Board of Commissioners will conduct a public hearing on April 12, 2021, at 6:00 PM in Room 103 of the CVCC / Alexander Center in Taylorsville, North Carolina. The purpose of the hearing is to receive public feedback on a proposal to request the NC General Assembly for a Local Act changing the election method of the Alexander County Board of Education from nonpartisan to partisan while retaining school district representation.</p> <p></span></div> </div> <div class="" data-block="true" data-editor="b4pk1" data-offset-key="veip-0-0"> <div class="_1mf _1mj" data-offset-key="ccrf9-0-0"><span data-offset-key="ccrf9-0-0">The proposed resolution is available for public inspection in the office of the Clerk to the Board / County Administration Office (621 Liledoun Road, Taylorsville, NC) between the hours of 8:00 AM and 5:00 PM Monday through Friday. For more information or to sign up to speak during the public hearing, call (828) 632-9332.</p> <p></span></div> <div class="_1mf _1mj" style="padding-left: 40px;" data-offset-key="ccrf9-0-0"><span data-offset-key="ccrf9-0-0">Jamie M. Starnes </span></div> <div class="_1mf _1mj" style="padding-left: 40px;" data-offset-key="ccrf9-0-0"><span data-offset-key="ccrf9-0-0">Clerk to the Board</span></div> </div> <div class="" data-block="true" data-editor="b4pk1" data-offset-key="1aa6r-0-0"> <div class="_1mf _1mj" style="padding-left: 40px;" data-offset-key="1aa6r-0-0"><span data-offset-key="1aa6r-0-0">Alexander County</span></div> </div> </div> <div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.taylorsvilletimes.com/2021/04/09/commissioners-propose-changing-school-board-election-to-partisan/" data-a2a-title="Commissioners propose changing school board election to partisan"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F04%2F09%2Fcommissioners-propose-changing-school-board-election-to-partisan%2F&amp;linkname=Commissioners%20propose%20changing%20school%20board%20election%20to%20partisan" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F04%2F09%2Fcommissioners-propose-changing-school-board-election-to-partisan%2F&amp;linkname=Commissioners%20propose%20changing%20school%20board%20election%20to%20partisan" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_printfriendly" href="https://www.addtoany.com/add_to/printfriendly?linkurl=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F04%2F09%2Fcommissioners-propose-changing-school-board-election-to-partisan%2F&amp;linkname=Commissioners%20propose%20changing%20school%20board%20election%20to%20partisan" title="PrintFriendly" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div> </div> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags">Posted in <a href="https://www.taylorsvilletimes.com/category/breaking-news/" rel="category tag">Breaking News</a>, <a href="https://www.taylorsvilletimes.com/category/news/" rel="category tag">News</a></div></div> <div class="fl-comments"> <div id="respond"> <h3 class="fl-comments-respond-title">Leave a Comment</h3> <form class="fl-comment-form" action="https://www.taylorsvilletimes.com/wp-comments-post.php" method="post"> <label for="author">Name (required)</label> <input type="text" name="author" class="form-control" value="" tabindex="1" aria-required='true' /> <br/> <label for="email">Email (will not be published) (required)</label> <input type="text" name="email" class="form-control" value="" tabindex="2" aria-required='true' /> <br/> <label for="comment">Comment</label> <textarea name="comment" class="form-control" cols="60" rows="8" tabindex="4"></textarea> <br/> <div class="g-recaptcha" data-sitekey="6LdvRcMZAAAAAEXIplzSR6ZvSkSZTV1inA8BbwkV"></div> <br> <input name="submit" type="submit" class="btn btn-primary" tabindex="5" value="Submit Comment"/> <input type='hidden' name='comment_post_ID' value='250790' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /> <div class="fl-comment-form-cancel"> <a rel="nofollow" id="cancel-comment-reply-link" href="/2021/04/09/commissioners-propose-changing-school-board-election-to-partisan/#respond" style="display:none;">Click here to cancel reply.</a> </div> </form> </div> </div> <style>
                    .fl-post-featured-post {
                        border-bottom: 1px solid #e6e6e6;
                        margin-bottom: 10px;
                        padding-bottom: 0px;
                        margin-left: 20px;
                    }

                    .fl-post-featured-image-beside .fl-post-featured-image {
                        float: left;
                        width: 120px;
                        padding-right: 5px;
                    }

                    .fl-clear {
                        clear: both;
                    }

                    h5.fl-post-featured-title {
                        margin: 0 0 10px;
                        padding: 0;
                        font-weight: bold;
                    }

                    .fl-post-featured-image {
                        margin-bottom: 10px;
                    }

                    .fl-post-featured-image img {
                        height: auto !important;
                        width: 100% !important;
                    }

                    .fl-post-featured-header {
                        margin-bottom: 15px;
                    }

                </style> <div id="webads-related-posts"> <h3>Related Posts</h3> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/04/09/volunteers-being-sought-for-litter-sweep/" rel="bookmark" title="Volunteers being sought for Litter Sweep"> <img width="300" height="187" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/04/litter-sweep-e1618001950760-300x187.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/04/09/volunteers-being-sought-for-litter-sweep/" rel="bookmark" title="Volunteers being sought for Litter Sweep">Volunteers being sought for Litter Sweep</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> April 9, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/04/09/volunteers-being-sought-for-litter-sweep/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/04/07/vaccines-open-to-all-age-16/" rel="bookmark" title="Vaccines open to all age 16+"> <img width="300" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2020/11/covid-N2004P64042C-sq-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/04/07/vaccines-open-to-all-age-16/" rel="bookmark" title="Vaccines open to all age 16+">Vaccines open to all age 16+</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> April 7, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/04/07/vaccines-open-to-all-age-16/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/04/07/two-people-shot-several-arrested-in-april-6-incident/" rel="bookmark" title="Two people shot, several arrested in April 6 incident"> <img width="300" height="299" src="https://www.taylorsvilletimes.com/wp-content/uploads/2019/02/gun-web-300x299.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/04/07/two-people-shot-several-arrested-in-april-6-incident/" rel="bookmark" title="Two people shot, several arrested in April 6 incident">Two people shot, several arrested in April 6 incident</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> April 7, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/04/07/two-people-shot-several-arrested-in-april-6-incident/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/04/07/fire-death-reported-april-7-in-hiddenite/" rel="bookmark" title="Fire, death reported April 7 in Hiddenite"> <img width="300" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/04/04-07-21-Fire-fatality-on-Ervin-Lane-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/04/07/fire-death-reported-april-7-in-hiddenite/" rel="bookmark" title="Fire, death reported April 7 in Hiddenite">Fire, death reported April 7 in Hiddenite</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> April 7, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/04/07/fire-death-reported-april-7-in-hiddenite/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/03/31/vaccines-open-to-all-essential-workers-group-4-on-mar-31/" rel="bookmark" title="Vaccines open to all essential workers, Group 4, on Mar. 31"> <img width="300" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/03/0vax-N2103P68003C-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/03/31/vaccines-open-to-all-essential-workers-group-4-on-mar-31/" rel="bookmark" title="Vaccines open to all essential workers, Group 4, on Mar. 31">Vaccines open to all essential workers, Group 4, on Mar. 31</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> March 31, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/03/31/vaccines-open-to-all-essential-workers-group-4-on-mar-31/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> </div> </article> </div> <div class="fl-sidebar fl-sidebar-right fl-sidebar-display-always col-md-3" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"> <aside id="adrotate_widgets-2" class="fl-widget widget_adrotate_widgets"><div class="g g-1"><div class="g-dyn a-18 c-1"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Jobs', 1.00, {'nonInteraction': 1});" href="http://www.hometownemploymentnetwork.com/default.aspx?affiliateid=1137" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Jobs', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2016/09/jobs.jpg" /></a></div><div class="g-dyn a-3 c-2"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Adams Funeral Home - Spotlight', 1.00, {'nonInteraction': 1});" href="http://www.adamsfunerals.com" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Adams Funeral Home - Spotlight', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2017/01/Adams-Funeral-BC-2017.jpg" /></a></div><div class="g-dyn a-26 c-3"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Service Directory', 1.00, {'nonInteraction': 1});" href="https://www.taylorsvilletimes.com/business-service-directory/"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Service Directory', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2017/08/Service-Directory-BC-for-web-2017.jpg" /></a></div><div class="g-dyn a-5 c-4"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Hendren Insurance', 1.00, {'nonInteraction': 1});" href="http://www.hendreninsurance.com/" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Hendren Insurance', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/02/Hendren-Insurance-BC-2021.jpg" /></a></div></div></aside><aside id="adrotate_widgets-3" class="fl-widget widget_adrotate_widgets"><div class="a-single a-10"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Breaking News Signup', 1.00, {'nonInteraction': 1});" href="https://www.taylorsvilletimes.com/breaking-news-signup/"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Breaking News Signup', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2016/10/breakingNewsHeader.png" /></a></div></aside><aside id="polls-widget-2" class="fl-widget widget_polls-widget"><h4 class="fl-widget-title">Online Poll</h4>Thank you for participating in our poll.<ul><li><a href="https://www.taylorsvilletimes.com/pollsarchive">Polls Archive</a></li></ul></aside><aside id="webads_displayads_widget-2" class="fl-widget widget_webads_displayads_widget"> <style>
                    #displayAds img {
                        width: 100%;
                        height: auto;
                    }

                                        #displayAdsWrapper {
                        height: 1500px;
                        overflow: hidden;
                    }
                    

                </style> <div id="displayAdsWrapper"> <div id="displayAds"> <ul id="displayAdsUL"> </ul> </div> </div>  <div id="displayAdDirLink"><h3><a href="https://www.taylorsvilletimes.com/1709/advertiser-directory">View All Advertisers</h3></div></aside> </div> </div> </div> </div> </div> <footer class="fl-page-footer-wrap" itemscope="itemscope" itemtype="http://schema.org/WPFooter"> <div class="fl-page-footer-widgets"> <div class="fl-page-footer-widgets-container container"> <div class="fl-page-footer-widgets-row row"> <div class="col-sm-4 col-md-4"><aside id="nav_menu-3" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">The Taylorsville Times</h4><div class="menu-footer-menu-1-container"><ul id="menu-footer-menu-1" class="menu"><li id="menu-item-228" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-228"><a href="https://www.taylorsvilletimes.com/">Home</a></li> <li id="menu-item-229" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-229"><a href="https://www.taylorsvilletimes.com/contact-us/">Contact Us</a></li> <li id="menu-item-24392" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24392"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=ebf2cc70-aaa6-40ab-ac88-1de546069d6d">The Taylorsville Times</a></li> <li id="menu-item-24391" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24391"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=4b944019-7f68-4c98-beee-fd6f2e06aaaa">The Bethlehem Star</a></li> <li id="menu-item-24390" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24390"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=fced17f6-97f1-4d30-9c1f-2b478c0f1936">125th Anniversary Edition</a></li> <li id="menu-item-231" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-231"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=ebf2cc70-aaa6-40ab-ac88-1de546069d6d&#038;view=subscribe">Subscribe</a></li> <li id="menu-item-23835" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23835"><a href="https://www.taylorsvilletimes.com/copyright/">Copyright</a></li> <li id="menu-item-23836" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23836"><a href="https://www.taylorsvilletimes.com/times-history/">Times&#8217; History</a></li> <li id="menu-item-23837" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23837"><a href="https://www.taylorsvilletimes.com/advertising-rates/">Advertising Rates</a></li> <li id="menu-item-23839" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23839"><a href="https://www.taylorsvilletimes.com/where-to-buy-the-times/">Where To Buy The Times</a></li> </ul></div></aside></div><div class="col-sm-4 col-md-4"><aside id="webads_syndicated_stories_menu_widget-2" class="fl-widget widget_webads_syndicated_stories_menu_widget"><h4 class="fl-widget-title">US &#038; World News</h4> <div><ul class="menu"> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/united-states/">US</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/sports/">Sports</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/entertainment/">Entertainment</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/technology/">Technology</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/political/">Politics</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/world/">World</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/business/">Business</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/health/">Health</a></li> </ul></div> </aside></div><div class="col-sm-4 col-md-4"><aside id="nav_menu-5" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">Odds &#038; Ends</h4><div class="menu-footer-menu-3-container"><ul id="menu-footer-menu-3" class="menu"><li id="menu-item-216" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-216"><a href="https://www.taylorsvilletimes.com/crossword/">Crossword Puzzle</a></li> <li id="menu-item-217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-217"><a href="https://www.taylorsvilletimes.com/event-calendar/">Event Calendar</a></li> <li id="menu-item-1473" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1473"><a href="https://www.taylorsvilletimes.com/poll/">Online Poll</a></li> <li id="menu-item-218" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218"><a href="https://www.taylorsvilletimes.com/photos/">Photo Galleries</a></li> <li id="menu-item-23840" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23840"><a href="https://www.taylorsvilletimes.com/meet-us-on-social-media/">Meet us on social media</a></li> </ul></div></aside></div> </div> </div> </div><div class="fl-page-footer"> <div class="fl-page-footer-container container"> <div class="fl-page-footer-row row"> <div class="col-md-12 text-center clearfix"><div class="fl-page-footer-text fl-page-footer-text-1">This website is powered by <a href="http://www.websitesfornewspapers.com" target="_blank"><i><strong>WebsitesForNewspapers.com</strong></i></a></div></div> </div> </div> </div> </footer>            
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script></body></html>
<!--
Cached page generated by Borlabs Cache - more information https://borlabs.io/
Time to create cache: 3.17461896 sec
Time to load cache: 0.08338213
Cache file created on: 2021-04-09T21:35:27+00:00
Current time: 2021-04-09T22:54:23+00:00
-->