<!DOCTYPE html> <html lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml"> <head><link rel="dns-prefetch" href="//ajax.googleapis.com">
<link rel="dns-prefetch" href="//www.google.com">
<link rel="dns-prefetch" href="//fonts.googleapis.com">
<link rel="preload" href="https://www.taylorsvilletimes.com/wp-content/cache/borlabs_cache/1/js/5b5628b42ff49e2467c3859c4e58f6b0ab1f1295_https.js" as="script">
<link rel="preload" href="https://www.taylorsvilletimes.com/wp-content/cache/borlabs_cache/1/css/30c169d1e8d99505890b27151768b218facd4723_https.css" as="style">
<link rel="stylesheet" href="https://www.taylorsvilletimes.com/wp-content/cache/borlabs_cache/1/css/30c169d1e8d99505890b27151768b218facd4723_https.css" type="text/css" media="all"><link href="https://fonts.googleapis.com/css?family=Oswald%3A400" rel="stylesheet"> <meta charset="UTF-8" /> <meta name="viewport" content="width=device-width, initial-scale=1.0" /> <meta http-equiv="X-UA-Compatible" content="IE=edge" /> <link rel="profile" href="https://gmpg.org/xfn/11" /> <link rel="pingback" href="https://www.taylorsvilletimes.com/xmlrpc.php" />   <!--[if lt IE 9]> <script src="https://www.taylorsvilletimes.com/wp-content/themes/bb-theme/js/html5shiv.js"></script> <script src="https://www.taylorsvilletimes.com/wp-content/themes/bb-theme/js/respond.min.js"></script> <![endif]--> <title>Judy Payne Chapman &#8211; The Taylorsville Times</title>  <link rel='dns-prefetch' href='//ajax.googleapis.com' /> <link rel='dns-prefetch' href='//www.google.com' /> <link rel="alternate" type="application/rss+xml" title="The Taylorsville Times &raquo; Feed" href="https://www.taylorsvilletimes.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="The Taylorsville Times &raquo; Comments Feed" href="https://www.taylorsvilletimes.com/comments/feed/" /> <link rel="alternate" type="application/rss+xml" title="The Taylorsville Times &raquo; Judy Payne Chapman Comments Feed" href="https://www.taylorsvilletimes.com/2021/05/09/judy-payne-chapman/feed/" /> <meta property="og:title" content="Judy Payne Chapman"/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.taylorsvilletimes.com/2021/05/09/judy-payne-chapman/"/><meta property="og:site_name" content="The Taylorsville Times"/><meta property="og:image" content="https://www.taylorsvilletimes.com/wp-content/uploads/2021/05/Judy-Chapman-pic1.jpg"/>                      <style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 8px;
	line-height: 10px;
	height: 10px;
	background-image: url('https://www.taylorsvilletimes.com/wp-content/plugins/webads-polls/images/default_gradient/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>                                                   <link rel="https://api.w.org/" href="https://www.taylorsvilletimes.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.taylorsvilletimes.com/wp-json/wp/v2/posts/251058" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.taylorsvilletimes.com/xmlrpc.php?rsd" /> <link rel='prev' title='Patsy Ruth Tedder Wike' href='https://www.taylorsvilletimes.com/2021/05/06/patsy-ruth-tedder-wike/' /> <link rel="canonical" href="https://www.taylorsvilletimes.com/2021/05/09/judy-payne-chapman/" /> <link rel='shortlink' href='https://www.taylorsvilletimes.com/?p=251058' /> <link rel="alternate" type="application/json+oembed" href="https://www.taylorsvilletimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F05%2F09%2Fjudy-payne-chapman%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://www.taylorsvilletimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F05%2F09%2Fjudy-payne-chapman%2F&#038;format=xml" />  <style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:175px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>  <link rel="shortcut icon" href="https://www.taylorsvilletimes.com/wp-content/uploads/2021/03/favicon-16x16-1.png"/>  <style id="fl-theme-custom-css">.widget_execphp {
    font-weight: bold;
    padding-top: 20px;
}</style> <script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js?ver=1.12.4' id='jquery-js'></script><script type='text/javascript' src='https://www.google.com/recaptcha/api.js?ver=5.5.3' id='recaptcha-scripts-js'></script><script type="text/javascript" src="https://www.taylorsvilletimes.com/wp-content/cache/borlabs_cache/1/js/5b5628b42ff49e2467c3859c4e58f6b0ab1f1295_https.js"></script></head> <body class="post-template-default single single-post postid-251058 single-format-standard ecwd-theme-parent-bb-theme ecwd-theme-child-bb-theme-child fl-preset-color01 fl-fixed-width" itemscope="itemscope" itemtype="http://schema.org/WebPage"> <div> <div class="fl-page-bar"> <div class="fl-page-bar-container container"> <div class="fl-page-bar-row row"> <div class="col-md-8 hidden-sm text-left clearfix"> <div class="breakingNews" id="bn7"> <div class="bn-title"><h2>Breaking News</h2><span></span></div> <ul> <li><a href="https://www.taylorsvilletimes.com/2021/05/05/proposed-town-budget-would-keep-same-tax-rate/">Proposed Town budget would keep same tax rate</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/05/05/barnes-named-times-mother-of-the-year/">Barnes named Times’ Mother of the Year</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/04/28/gov-to-relax-states-outdoor-mask-mandate/">Gov. to Relax State’s Outdoor Mask Mandate</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/04/28/etbc-recognized-by-town-council/">ETBC recognized by Town Council</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/04/28/pediatric-therapy-network-now-open/">Pediatric Therapy Network now open</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/04/28/bid-approved-for-courthouse-park/">Bid approved for Courthouse Park</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/04/23/school-board-asking-1-1m-for-old-wittenburg-school/">School Board asking $1.1M for Old Wittenburg School</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/04/22/governor-outlines-timeline-for-lifting-covid-19-restrictions/">Governor outlines timeline for lifting COVID-19 restrictions</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/04/21/onstar-helps-deputies-end-car-chase/">OnStar helps deputies end car chase</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/04/21/times-mother-of-the-year-contest-deadline-may-12/">Times’ Mother of the Year Contest deadline April 29</a></li> </ul> <div class="bn-navi"> <span></span> <span></span> </div> </div>  <div class="fl-page-bar-text fl-page-bar-text-1"></div></div> <div class="col-md-4 col-sm-12 text-right clearfix"><ul class="fl-page-bar-nav nav navbar-nav menu"><li><a href="https://www.taylorsvilletimes.com">Home</a></li></ul><div class="fl-social-icons"><a href="https://www.facebook.com/taylorsvilletimes" target="_blank" class="fl-icon fl-icon-color-mono fl-icon-facebook fl-icon-facebook-regular"></a><a href="https://twitter.com/Tville_Times" target="_blank" class="fl-icon fl-icon-color-mono fl-icon-twitter fl-icon-twitter-regular"></a><a href="https://instagram.com/taylorsvilletimes" target="_blank" class="fl-icon fl-icon-color-mono fl-icon-instagram fl-icon-instagram-regular"></a><a href="/cdn-cgi/l/email-protection#127c7765615266736b7e7d6061647b7e7e77667b7f77613c717d7f" class="fl-icon fl-icon-color-mono fl-icon-email fl-icon-email-regular"></a></div></div> </div> </div> </div></div> <div class="fl-page"> <header class="fl-page-header fl-page-header-primary fl-page-nav-bottom fl-page-nav-toggle-button" itemscope="itemscope" itemtype="http://schema.org/WPHeader"> <div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="col-md-8 col-sm-8"> <div class="fl-page-header-logo" itemscope="itemscope" itemtype="http://schema.org/Organization"> <a href="https://www.taylorsvilletimes.com" itemprop="url"><img class="fl-logo-img" itemscope itemtype="http://schema.org/ImageObject" src="https://www.taylorsvilletimes.com/wp-content/uploads/2016/09/Taylorsville-Times-Banner.jpg" data-retina="" alt="The Taylorsville Times" /><meta itemprop="name" content="The Taylorsville Times" /></a> </div> </div> <div class="col-md-4 col-sm-4"> <div class="fl-page-header-content"> <div id="webads_weather_widget-2" class="widget widget_webads_weather_widget pull-right">  <div id="webads-weather-28681" class="widget widget-webads-weather"> <a id="webads-weather-28681-link" href="https://www.taylorsvilletimes.com"> <div class="awe-mini"> <div> <div class="col visual"> <span id="webads-weather-28681-temperature" class="temperature"></span> <i id="webads-weather-28681-image" class="weather-forecast-icon" style="background-size:contain"></i> </div> <div class="col info"> <span id="webads-weather-28681-location" class="location"></span> <span id="webads-weather-28681-conditions" class="forecast"></span> </div> </div> </div> </a> </div>  </div><div id="search-2" class="widget widget_search pull-right"><form method="get" role="search" action="https://www.taylorsvilletimes.com" title="Type and press Enter to search."> <input type="text" class="fl-search-input" name="s" class="form-control" value="Search" onfocus="if (this.value == 'Search') { this.value = ''; }" onblur="if (this.value == '') this.value='Search';"> </form></div><div id="execphp-2" class="widget widget_execphp pull-right"> <div class="execphpwidget">May 10, 2021</div> </div> </div> </div> </div> </div> </div> <div class="fl-page-nav-wrap"> <div class="fl-page-nav-container container"> <nav class="fl-page-nav navbar navbar-default" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span>Menu</span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-main-menu" class="nav navbar-nav menu"><li id="menu-item-1076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-has-children menu-item-1076"><a href="https://www.taylorsvilletimes.com/">Home</a> <ul class="sub-menu"> <li id="menu-item-24448" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24448"><a href="https://www.taylorsvilletimes.com/category/breaking-news/">Breaking News</a></li> <li id="menu-item-766" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-766"><a href="https://www.taylorsvilletimes.com/category/sports/">Sports</a></li> <li id="menu-item-24446" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-24446"><a href="#">Connect</a> <ul class="sub-menu"> <li id="menu-item-23828" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23828"><a href="https://www.taylorsvilletimes.com/advertising-rates/">Advertising Rates</a></li> <li id="menu-item-23425" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-23425"><a target="_blank" rel="noopener noreferrer" href="http://taylorsvillenc.ors.kwnews.com/">Church Directory</a> <ul class="sub-menu"> <li id="menu-item-23426" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23426"><a target="_blank" rel="noopener noreferrer" href="http://taylorsvillenc.ors.kwnews.com/page">Church of the Week</a></li> </ul> </li> <li id="menu-item-289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-289"><a href="https://www.taylorsvilletimes.com/crossword/">Crossword</a></li> <li id="menu-item-23434" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23434"><a href="https://www.taylorsvilletimes.com/meet-us-on-social-media/">Social media &#038; Our Podcast</a></li> <li id="menu-item-290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-290"><a href="https://www.taylorsvilletimes.com/event-calendar/">Events</a></li> <li id="menu-item-293" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-293"><a href="https://www.taylorsvilletimes.com/photos/">Photos</a></li> <li id="menu-item-46641" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46641"><a href="https://www.taylorsvilletimes.com/public-forum/">Public Forum</a></li> <li id="menu-item-23832" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23832"><a href="https://www.taylorsvilletimes.com/times-history/">Times’ History</a></li> <li id="menu-item-23435" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23435"><a href="https://www.taylorsvilletimes.com/where-to-buy-the-times/">Where To Buy The Times</a></li> </ul> </li> </ul> </li> <li id="menu-item-43221" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43221"><a href="https://www.taylorsvilletimes.com/obituaries/">Obituaries</a></li> <li id="menu-item-296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-296"><a href="#">E-Editions</a> <ul class="sub-menu"> <li id="menu-item-24389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24389"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=ebf2cc70-aaa6-40ab-ac88-1de546069d6d">The Taylorsville Times</a></li> <li id="menu-item-24388" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24388"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=4b944019-7f68-4c98-beee-fd6f2e06aaaa">The Bethlehem Star</a></li> <li id="menu-item-246558" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-246558"><a href="https://www.taylorsvilletimes.com/2020/03/05/why-i-love-alexander-county-an-essay-series/">&#8220;I Love Alexander&#8221; Essays</a></li> <li id="menu-item-24387" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24387"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=fced17f6-97f1-4d30-9c1f-2b478c0f1936">125th Anniversary Edition</a></li> <li id="menu-item-42416" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-42416"><a href="#">Archives</a> <ul class="sub-menu"> <li id="menu-item-42417" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42417"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?view=archives&#038;Edition=4347a18b-eb96-4d2a-af00-10bd5e75bba0">The Taylorsville Times</a></li> <li id="menu-item-42418" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42418"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?view=archives&#038;Edition=1bb6cacb-0050-467b-abea-88afc18c2e90">The Bethlehem Star</a></li> </ul> </li> </ul> </li> <li id="menu-item-249508" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249508"><a href="https://www.taylorsvilletimes.com/2021/05/05/legal-notices-2/">LEGAL NOTICES</a></li> <li id="menu-item-24179" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-24179"><a href="https://www.taylorsvilletimes.com/category/classifieds/">Classifieds</a> <ul class="sub-menu"> <li id="menu-item-249509" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249509"><a href="https://www.taylorsvilletimes.com/2021/05/05/automotive/">AUTOMOTIVE</a></li> <li id="menu-item-249510" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249510"><a href="https://www.taylorsvilletimes.com/2021/05/05/for-rent-12/">FOR RENT</a></li> <li id="menu-item-249511" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249511"><a href="https://www.taylorsvilletimes.com/2021/05/05/for-sale-2/">FOR SALE</a></li> <li id="menu-item-249512" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249512"><a href="https://www.taylorsvilletimes.com/2021/05/05/general-4/">GENERAL</a></li> <li id="menu-item-249513" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249513"><a href="https://www.taylorsvilletimes.com/2021/05/05/help-wanted-9/">HELP WANTED</a></li> <li id="menu-item-249514" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249514"><a href="https://www.taylorsvilletimes.com/2021/05/05/wanted/">WANTED</a></li> <li id="menu-item-24137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24137"><a href="https://www.taylorsvilletimes.com/submit-a-classified/">Submit a Classified</a></li> </ul> </li> <li id="menu-item-23818" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-23818"><a href="#">Weekly Circulars</a> <ul class="sub-menu"> <li id="menu-item-23819" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23819"><a target="_blank" rel="noopener noreferrer" href="https://www.foodlion.com/weekly-specials/">Food Lion</a></li> </ul> </li> <li id="menu-item-244238" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-244238"><a href="https://www.taylorsvilletimes.com/business-service-directory/">Business Directory</a></li> </ul> </div> </nav> </div> </div> </header> <div class="fl-page-content" itemprop="mainContentOfPage"> <div class="webads-userbar-wrapper" style="display: none;"><span class="webads-userbar"><span class="webads-userbar-name"></span><span class="fl-sep"> | </span><a href="https://www.taylorsvilletimes.com/wp-admin/admin-post.php?action=webads_logout&webads_logout_nonce=DS9URN7DtQcxre6U"><span>logout</span></a></span></div>  <div class="container"> <div class="row"> <div class="fl-content fl-content-left col-md-9"> <article class="fl-post post-251058 post type-post status-publish format-standard has-post-thumbnail hentry category-obituaries" id="fl-post-251058" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <header class="fl-post-header"> <h1 class="fl-post-title" itemprop="headline"> Judy Payne Chapman </h1> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person">By <a href="https://www.taylorsvilletimes.com/author/editor/" itemprop="url"><span itemprop="name">Editor</span></a></span><span class="fl-sep"> | </span><span class="fl-post-date" itemprop="datePublished" datetime="2021-05-09">May 9, 2021</span><span class="fl-sep"> | </span><span class="fl-comments-popup-link"><a href="https://www.taylorsvilletimes.com/2021/05/09/judy-payne-chapman/#respond">0 <i class="fa fa-comment"></i></a></span></div><meta itemprop="image" content="https://www.taylorsvilletimes.com/wp-content/uploads/2021/05/Judy-Chapman-pic1.jpg"><meta itemprop="interactionCount" content="UserComments:0"> </header> <div class="fl-post-content clearfix" itemprop="text"> <div id="attachment_251059" style="width: 250px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-251059" loading="lazy" class="wp-image-251059" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/05/Judy-Chapman-pic1-207x300.jpg" alt="" width="240" height="347" srcset="https://www.taylorsvilletimes.com/wp-content/uploads/2021/05/Judy-Chapman-pic1-207x300.jpg 207w, https://www.taylorsvilletimes.com/wp-content/uploads/2021/05/Judy-Chapman-pic1-707x1024.jpg 707w, https://www.taylorsvilletimes.com/wp-content/uploads/2021/05/Judy-Chapman-pic1-768x1112.jpg 768w, https://www.taylorsvilletimes.com/wp-content/uploads/2021/05/Judy-Chapman-pic1.jpg 829w" sizes="(max-width: 240px) 100vw, 240px" /><p id="caption-attachment-251059" class="wp-caption-text">Judy Payne Chapman</p></div> <p>Judy Payne Chapman, 80, of Taylorsville, went to her heavenly home on Sunday, May 9, 2021, at Gordon Hospice House in Statesville.</p> <p>Judy was born June 2, 1940, in Alexander County, the daughter of the late Ransom Vance Payne and Pearl Warren Payne.</p> <p>She had worked as a Transportation Aid for Wilkes Senior Citizens Council for Wilkes County before retiring. Judy enjoyed singing (great alto singer). She enjoyed going to church, loved her family, friends, church family, and reading her Bible; she read it through more than 28 times. She enjoyed helping people, especially senior citizens and enjoyed people; for she was a people person.</p> <p>Including her parents, she was preceded in death by two sisters, Catherine Payne Senter and Peggy Joyce Payne; two brothers, Roger Vance Payne and Christy Lindy Payne; two brothers-in-law, Shuford Deal and Bob Senter; father and mother-in-law, Uriah C. Chapman and Ruby Chapman; siblings-in-law, Alma Moore, Ethel Auton, Ralph Chapman, Estelle Chapman, Ruby Freeman, Vivian Gentle, Wade Chapman, Frances Lail, and Alan Chapman; and brother-in-law, Steven Warren.</p> <p>Those left to cherish and honor her memory include her husband, who she married August 6, 1967, Rev. Phil Chapman of the home; sons, Timothy Chapman, and Curtis Chapman and wife Sheri; grandson, Cole; sister, Jackie Payne Deal; two sisters-in-law, Nancy Faulk and Patty Payne; siblings-in-law, Larry Doby Chapman and wife Tootsie, Nancy Faulk and husband Rick, Danny Chapman and wife Melinda, Ann Warren, Guy Chapman and wife Penny, and Kathy Lail; brother-in-law, Jerry Lail; sister-in-law, Sherry Chapman; and a number of nieces, nephews, cousins, and friends.</p> <p>The funeral service will be held at 4 p.m., Thursday, May 13, 2021, at Liledoun Baptist Church. Rev. Jason Payne, Rev. Jeff Chapman, and Rev. Kyle Chapman will officiate. Burial will follow in the church cemetery. The family will receive friends from 2 -4 p.m. prior to the funeral service at the church. The body will lie in state from 9 a.m. until Noon, Thursday, May 13, 2021, at Adams Funeral Home.</p> <p>Pallbearers include Todd Payne, Scott Payne, Brad Payne, Dale Milstead, Mark Bumgarner, and Jody Chapman.</p> <p>Please apply all Covid-19 guidelines to all services.</p> <p>Memorials may be made to Samaritan Purse, PO Box 3000, Boone, NC 28607.</p> <p>Condolences may be sent to www.adamsfunerals.com.</p> <p>Adams Funeral Home and Cremation Services is serving the family of Judy Payne Chapman.</p> <div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.taylorsvilletimes.com/2021/05/09/judy-payne-chapman/" data-a2a-title="Judy Payne Chapman"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F05%2F09%2Fjudy-payne-chapman%2F&amp;linkname=Judy%20Payne%20Chapman" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F05%2F09%2Fjudy-payne-chapman%2F&amp;linkname=Judy%20Payne%20Chapman" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_printfriendly" href="https://www.addtoany.com/add_to/printfriendly?linkurl=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F05%2F09%2Fjudy-payne-chapman%2F&amp;linkname=Judy%20Payne%20Chapman" title="PrintFriendly" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div> </div> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags">Posted in <a href="https://www.taylorsvilletimes.com/category/obituaries/" rel="category tag">Obituaries</a></div></div> <div class="fl-comments"> <div id="respond"> <h3 class="fl-comments-respond-title">Leave a Comment</h3> <form class="fl-comment-form" action="https://www.taylorsvilletimes.com/wp-comments-post.php" method="post"> <label for="author">Name (required)</label> <input type="text" name="author" class="form-control" value="" tabindex="1" aria-required='true' /> <br/> <label for="email">Email (will not be published) (required)</label> <input type="text" name="email" class="form-control" value="" tabindex="2" aria-required='true' /> <br/> <label for="comment">Comment</label> <textarea name="comment" class="form-control" cols="60" rows="8" tabindex="4"></textarea> <br/> <div class="g-recaptcha" data-sitekey="6LdvRcMZAAAAAEXIplzSR6ZvSkSZTV1inA8BbwkV"></div> <br> <input name="submit" type="submit" class="btn btn-primary" tabindex="5" value="Submit Comment"/> <input type='hidden' name='comment_post_ID' value='251058' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /> <div class="fl-comment-form-cancel"> <a rel="nofollow" id="cancel-comment-reply-link" href="/2021/05/09/judy-payne-chapman/#respond" style="display:none;">Click here to cancel reply.</a> </div> </form> </div> </div> <style>
                    .fl-post-featured-post {
                        border-bottom: 1px solid #e6e6e6;
                        margin-bottom: 10px;
                        padding-bottom: 0px;
                        margin-left: 20px;
                    }

                    .fl-post-featured-image-beside .fl-post-featured-image {
                        float: left;
                        width: 120px;
                        padding-right: 5px;
                    }

                    .fl-clear {
                        clear: both;
                    }

                    h5.fl-post-featured-title {
                        margin: 0 0 10px;
                        padding: 0;
                        font-weight: bold;
                    }

                    .fl-post-featured-image {
                        margin-bottom: 10px;
                    }

                    .fl-post-featured-image img {
                        height: auto !important;
                        width: 100% !important;
                    }

                    .fl-post-featured-header {
                        margin-bottom: 15px;
                    }

                </style> <div id="webads-related-posts"> <h3>Related Posts</h3> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/05/06/patsy-ruth-tedder-wike/" rel="bookmark" title="Patsy Ruth Tedder Wike"> <img width="210" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/05/Patsy-Wike-pic-e1620484427118-210x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/05/06/patsy-ruth-tedder-wike/" rel="bookmark" title="Patsy Ruth Tedder Wike">Patsy Ruth Tedder Wike</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> May 6, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/05/06/patsy-ruth-tedder-wike/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/05/05/jill-d-mathews/" rel="bookmark" title="Jill D. Mathews"> <img width="184" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/05/Jill-Matthews-pic-e1620330111857-184x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/05/05/jill-d-mathews/" rel="bookmark" title="Jill D. Mathews">Jill D. Mathews</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> May 5, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/05/05/jill-d-mathews/#comments">1 Comment »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/05/04/judy-deal-thomas/" rel="bookmark" title="Judy Deal Thomas"> <img width="182" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/05/Judty-Thomas-pic-e1620335192481-182x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/05/04/judy-deal-thomas/" rel="bookmark" title="Judy Deal Thomas">Judy Deal Thomas</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> May 4, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/05/04/judy-deal-thomas/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/05/04/raymond-lawrence-shumate/" rel="bookmark" title="Raymond Lawrence Shumate"> <img width="177" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/05/Shumate-George-front-of-folder-5-21-e1620416145439-177x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/05/04/raymond-lawrence-shumate/" rel="bookmark" title="Raymond Lawrence Shumate">Raymond Lawrence Shumate</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> May 4, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/05/04/raymond-lawrence-shumate/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/05/03/carl-benjamin-wagner/" rel="bookmark" title="Carl Benjamin Wagner"> <img width="179" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/05/Wagner-Carl-HS_0001-e1620167854851-179x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/05/03/carl-benjamin-wagner/" rel="bookmark" title="Carl Benjamin Wagner">Carl Benjamin Wagner</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> May 3, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/05/03/carl-benjamin-wagner/#comments">1 Comment »</a></span> </div> </div> <div class="fl-clear"></div> </div> </div> </article> </div> <div class="fl-sidebar fl-sidebar-right fl-sidebar-display-always col-md-3" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"> <aside id="adrotate_widgets-2" class="fl-widget widget_adrotate_widgets"><div class="g g-1"><div class="g-dyn a-18 c-1"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Jobs', 1.00, {'nonInteraction': 1});" href="http://www.hometownemploymentnetwork.com/default.aspx?affiliateid=1137" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Jobs', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2016/09/jobs.jpg" /></a></div><div class="g-dyn a-26 c-2"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Service Directory', 1.00, {'nonInteraction': 1});" href="https://www.taylorsvilletimes.com/business-service-directory/"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Service Directory', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2017/08/Service-Directory-BC-for-web-2017.jpg" /></a></div><div class="g-dyn a-3 c-3"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Adams Funeral Home - Spotlight', 1.00, {'nonInteraction': 1});" href="http://www.adamsfunerals.com" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Adams Funeral Home - Spotlight', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2017/01/Adams-Funeral-BC-2017.jpg" /></a></div><div class="g-dyn a-5 c-4"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Hendren Insurance', 1.00, {'nonInteraction': 1});" href="http://www.hendreninsurance.com/" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Hendren Insurance', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/02/Hendren-Insurance-BC-2021.jpg" /></a></div></div></aside><aside id="adrotate_widgets-3" class="fl-widget widget_adrotate_widgets"><div class="a-single a-10"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Breaking News Signup', 1.00, {'nonInteraction': 1});" href="https://www.taylorsvilletimes.com/breaking-news-signup/"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Breaking News Signup', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2016/10/breakingNewsHeader.png" /></a></div></aside><aside id="polls-widget-2" class="fl-widget widget_polls-widget"><h4 class="fl-widget-title">Online Poll</h4><div id="polls-15" class="wp-polls">
	<form id="polls_form_15" class="wp-polls-form" action="/index.php" method="post">
		<p style="display: none;"><input type="hidden" id="poll_15_nonce" name="wp-polls-nonce" value="881f6f5f4f" /></p>
		<p style="display: none;"><input type="hidden" name="poll_id" value="15" /></p>
		<p style="display: none;"><input type="hidden" id="poll_multiple_ans_15" name="poll_multiple_ans_15" value="2" /></p>
		<p style="text-align: center;"><strong>Vote for the Taylorsville Times.Com Student Athlete of the Year (Vote for one male and one female)</strong></p><div id="polls-15-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
		<li><input type="checkbox" id="poll-answer-77" name="poll_15" value="77" /> <label for="poll-answer-77">Brianna Abernathy</label></li>
		<li><input type="checkbox" id="poll-answer-78" name="poll_15" value="78" /> <label for="poll-answer-78">Nikki Hagy</label></li>
		<li><input type="checkbox" id="poll-answer-79" name="poll_15" value="79" /> <label for="poll-answer-79">Gracie Harrington</label></li>
		<li><input type="checkbox" id="poll-answer-80" name="poll_15" value="80" /> <label for="poll-answer-80">Bryanna Payne</label></li>
		<li><input type="checkbox" id="poll-answer-81" name="poll_15" value="81" /> <label for="poll-answer-81">Ryheem Craig</label></li>
		<li><input type="checkbox" id="poll-answer-82" name="poll_15" value="82" /> <label for="poll-answer-82">Landon Dula</label></li>
		<li><input type="checkbox" id="poll-answer-83" name="poll_15" value="83" /> <label for="poll-answer-83">Zach Herman</label></li>
		<li><input type="checkbox" id="poll-answer-84" name="poll_15" value="84" /> <label for="poll-answer-84">Lance Justice</label></li>
		<li><input type="checkbox" id="poll-answer-85" name="poll_15" value="85" /> <label for="poll-answer-85">Blake Martin</label></li>
		<li><input type="checkbox" id="poll-answer-86" name="poll_15" value="86" /> <label for="poll-answer-86">Jacob Perez</label></li>
		</ul><p style="text-align: center;"><input type="button" name="vote" value="   Vote   " onclick="poll_vote(15);" /></p><p style="text-align: center;display: none;"><a href="#ViewPollResults" onclick="poll_result(15); return false;" title="View Results Of This Poll">View Results</a></p></div>
	</form>
</div>
<div id="polls-15-loading" class="wp-polls-loading"><img src="https://www.taylorsvilletimes.com/wp-content/plugins/webads-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
<ul><li><a href="https://www.taylorsvilletimes.com/pollsarchive">Polls Archive</a></li></ul></aside><aside id="webads_displayads_widget-2" class="fl-widget widget_webads_displayads_widget"> <style>
                    #displayAds img {
                        width: 100%;
                        height: auto;
                    }

                                        #displayAdsWrapper {
                        height: 1500px;
                        overflow: hidden;
                    }
                    

                </style> <div id="displayAdsWrapper"> <div id="displayAds"> <ul id="displayAdsUL"> </ul> </div> </div>  <div id="displayAdDirLink"><h3><a href="https://www.taylorsvilletimes.com/1709/advertiser-directory">View All Advertisers</h3></div></aside> </div> </div> </div> </div> </div> <footer class="fl-page-footer-wrap" itemscope="itemscope" itemtype="http://schema.org/WPFooter"> <div class="fl-page-footer-widgets"> <div class="fl-page-footer-widgets-container container"> <div class="fl-page-footer-widgets-row row"> <div class="col-sm-4 col-md-4"><aside id="nav_menu-3" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">The Taylorsville Times</h4><div class="menu-footer-menu-1-container"><ul id="menu-footer-menu-1" class="menu"><li id="menu-item-228" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-228"><a href="https://www.taylorsvilletimes.com/">Home</a></li> <li id="menu-item-229" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-229"><a href="https://www.taylorsvilletimes.com/contact-us/">Contact Us</a></li> <li id="menu-item-24392" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24392"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=ebf2cc70-aaa6-40ab-ac88-1de546069d6d">The Taylorsville Times</a></li> <li id="menu-item-24391" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24391"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=4b944019-7f68-4c98-beee-fd6f2e06aaaa">The Bethlehem Star</a></li> <li id="menu-item-24390" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24390"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=fced17f6-97f1-4d30-9c1f-2b478c0f1936">125th Anniversary Edition</a></li> <li id="menu-item-231" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-231"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=ebf2cc70-aaa6-40ab-ac88-1de546069d6d&#038;view=subscribe">Subscribe</a></li> <li id="menu-item-23835" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23835"><a href="https://www.taylorsvilletimes.com/copyright/">Copyright</a></li> <li id="menu-item-23836" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23836"><a href="https://www.taylorsvilletimes.com/times-history/">Times&#8217; History</a></li> <li id="menu-item-23837" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23837"><a href="https://www.taylorsvilletimes.com/advertising-rates/">Advertising Rates</a></li> <li id="menu-item-23839" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23839"><a href="https://www.taylorsvilletimes.com/where-to-buy-the-times/">Where To Buy The Times</a></li> </ul></div></aside></div><div class="col-sm-4 col-md-4"><aside id="webads_syndicated_stories_menu_widget-2" class="fl-widget widget_webads_syndicated_stories_menu_widget"><h4 class="fl-widget-title">US &#038; World News</h4> <div><ul class="menu"> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/united-states/">US</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/sports/">Sports</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/entertainment/">Entertainment</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/technology/">Technology</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/political/">Politics</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/world/">World</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/business/">Business</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/health/">Health</a></li> </ul></div> </aside></div><div class="col-sm-4 col-md-4"><aside id="nav_menu-5" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">Odds &#038; Ends</h4><div class="menu-footer-menu-3-container"><ul id="menu-footer-menu-3" class="menu"><li id="menu-item-216" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-216"><a href="https://www.taylorsvilletimes.com/crossword/">Crossword Puzzle</a></li> <li id="menu-item-217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-217"><a href="https://www.taylorsvilletimes.com/event-calendar/">Event Calendar</a></li> <li id="menu-item-1473" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1473"><a href="https://www.taylorsvilletimes.com/poll/">Online Poll</a></li> <li id="menu-item-218" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218"><a href="https://www.taylorsvilletimes.com/photos/">Photo Galleries</a></li> <li id="menu-item-23840" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23840"><a href="https://www.taylorsvilletimes.com/meet-us-on-social-media/">Meet us on social media</a></li> </ul></div></aside></div> </div> </div> </div><div class="fl-page-footer"> <div class="fl-page-footer-container container"> <div class="fl-page-footer-row row"> <div class="col-md-12 text-center clearfix"><div class="fl-page-footer-text fl-page-footer-text-1">This website is powered by <a href="http://www.websitesfornewspapers.com" target="_blank"><i><strong>WebsitesForNewspapers.com</strong></i></a></div></div> </div> </div> </div> </footer>            
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script></body></html>
<!--
Cached page generated by Borlabs Cache - more information https://borlabs.io/
Time to create cache: 3.18737507 sec
Time to load cache: 0.5805409
Cache file created on: 2021-05-10T16:37:13+00:00
Current time: 2021-05-10T17:48:57+00:00
-->