<!DOCTYPE html> <html lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml"> <head><link rel="dns-prefetch" href="//ajax.googleapis.com">
<link rel="dns-prefetch" href="//www.google.com">
<link rel="dns-prefetch" href="//fonts.googleapis.com">
<link rel="preload" href="https://www.taylorsvilletimes.com/wp-content/cache/borlabs_cache/1/js/d670ee0ae33402b6830c626b04269be292ab54f3_https.js" as="script">
<link rel="preload" href="https://www.taylorsvilletimes.com/wp-content/cache/borlabs_cache/1/css/f4f8bbaa4151eda9a8dbcc7927fec9299cd9e35f_https.css" as="style">
<link rel="stylesheet" href="https://www.taylorsvilletimes.com/wp-content/cache/borlabs_cache/1/css/f4f8bbaa4151eda9a8dbcc7927fec9299cd9e35f_https.css" type="text/css" media="all"><link href="https://fonts.googleapis.com/css?family=Oswald%3A400" rel="stylesheet"> <meta charset="UTF-8" /> <meta name="viewport" content="width=device-width, initial-scale=1.0" /> <meta http-equiv="X-UA-Compatible" content="IE=edge" /> <link rel="profile" href="http://gmpg.org/xfn/11" /> <link rel="pingback" href="https://www.taylorsvilletimes.com/xmlrpc.php" />   <!--[if lt IE 9]> <script src="https://www.taylorsvilletimes.com/wp-content/themes/bb-theme/js/html5shiv.js"></script> <script src="https://www.taylorsvilletimes.com/wp-content/themes/bb-theme/js/respond.min.js"></script> <![endif]--> <title>Lonnie Eugene Vickers &#8211; The Taylorsville Times</title>  <link rel='dns-prefetch' href='//ajax.googleapis.com' /> <link rel='dns-prefetch' href='//www.google.com' /> <link rel='dns-prefetch' href='//fonts.googleapis.com' /> <link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /> <link rel="alternate" type="application/rss+xml" title="The Taylorsville Times &raquo; Feed" href="https://www.taylorsvilletimes.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="The Taylorsville Times &raquo; Comments Feed" href="https://www.taylorsvilletimes.com/comments/feed/" /> <link rel="alternate" type="application/rss+xml" title="The Taylorsville Times &raquo; Lonnie Eugene Vickers Comments Feed" href="https://www.taylorsvilletimes.com/2021/11/26/lonnie-eugene-vickers/feed/" /> <meta property="og:title" content="Lonnie Eugene Vickers"/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.taylorsvilletimes.com/2021/11/26/lonnie-eugene-vickers/"/><meta property="og:site_name" content="The Taylorsville Times"/><meta property="og:image" content="https://www.taylorsvilletimes.com/wp-content/uploads/2021/11/Lonnie-Vickers-1.jpg"/>                       <style id='wp-polls-inline-css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 8px;
	line-height: 10px;
	height: 10px;
	background-image: url('https://www.taylorsvilletimes.com/wp-content/plugins/webads-polls/images/default_gradient/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>                                                        <link rel="https://api.w.org/" href="https://www.taylorsvilletimes.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.taylorsvilletimes.com/wp-json/wp/v2/posts/252943" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.taylorsvilletimes.com/xmlrpc.php?rsd" /> <link rel='prev' title='Geraldine “Gerri” Combs Benfield' href='https://www.taylorsvilletimes.com/2021/11/25/geraldine-gerri-combs-benfield/' /> <link rel="canonical" href="https://www.taylorsvilletimes.com/2021/11/26/lonnie-eugene-vickers/" /> <link rel='shortlink' href='https://www.taylorsvilletimes.com/?p=252943' /> <link rel="alternate" type="application/json+oembed" href="https://www.taylorsvilletimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F11%2F26%2Flonnie-eugene-vickers%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://www.taylorsvilletimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F11%2F26%2Flonnie-eugene-vickers%2F&#038;format=xml" />  <style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:175px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>  <link rel="shortcut icon" href="https://www.taylorsvilletimes.com/wp-content/uploads/2021/03/favicon-16x16-1.png"/>  <style id="wp-custom-css">
			

/*
CSS Migrated from BB theme:
*/

.widget_execphp {
    font-weight: bold;
    padding-top: 20px;
}		</style> <script src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js?ver=1.12.4' id='jquery-js'></script><script src='https://www.google.com/recaptcha/api.js?ver=5.5.7' id='recaptcha-scripts-js'></script><script type="text/javascript" src="https://www.taylorsvilletimes.com/wp-content/cache/borlabs_cache/1/js/d670ee0ae33402b6830c626b04269be292ab54f3_https.js"></script></head> <body class="post-template-default single single-post postid-252943 single-format-standard ecwd-theme-parent-bb-theme ecwd-theme-child-bb-theme-child fl-framework-bootstrap fl-preset-color01 fl-fixed-width fl-has-sidebar" itemscope="itemscope" itemtype="http://schema.org/WebPage"> <a aria-label="Skip to content" class="fl-screen-reader-text" href="#fl-main-content">Skip to content</a><div> <div class="fl-page-bar"> <div class="fl-page-bar-container container"> <div class="fl-page-bar-row row"> <div class="col-md-8 hidden-sm text-left clearfix"> <div class="breakingNews" id="bn7"> <div class="bn-title"><h2>Breaking News</h2><span></span></div> <ul> <li><a href="https://www.taylorsvilletimes.com/2021/11/23/office-holiday-closings-listed/">Office holiday closings listed</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/11/23/coy-reese-named-alexander-christmas-parade-grand-marshal/">Coy Reese named Alexander Christmas Parade Grand Marshal</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/11/10/employee-retention-bonus-announced-at-board-of-education-meeting-nov-9/">Employee Retention Bonus announced at Board of Education meeting Nov. 9</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/11/08/flag-retirement-box-debuts-at-register-of-deeds-office/">Flag Retirement Box debuts at Register of Deeds Office</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/11/03/county-tap-on-to-the-new-water-lines-soon-for-lower-fee/">County: Tap on to the new water lines soon for lower fee</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/11/01/masks-optional-in-schools-nov-1-5/">Masks optional in schools Nov. 1-5</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/10/28/man-and-ex-girlfriend-arrested-for-sex-crimes-against-her-daughter/">Man and ex-girlfriend arrested for sex crimes against her daughter</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/10/28/oct-28-is-first-responders-day/">Oct. 28 is First Responders Day</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/10/25/simpson-nominated-for-rack-room-shoes-teacher-of-year/">Simpson, Wills nominated for Rack Room Shoes Teacher of Year</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/10/25/alex-library-offers-cider-donuts-books-oct-29/">Alex. Library offers cider, donuts, books Oct. 29</a></li> </ul> <div class="bn-navi"> <span></span> <span></span> </div> </div>  <div class="fl-page-bar-text fl-page-bar-text-1"></div></div> <div class="col-md-4 col-sm-12 text-right clearfix"><ul class="fl-page-bar-nav nav navbar-nav menu"><li><a class="no-menu" href="https://www.taylorsvilletimes.com/">Home</a></li></ul> <div class="fl-social-icons"> <a href="https://www.facebook.com/taylorsvilletimes" target="_blank" rel="noopener noreferrer"><span class="sr-only">Facebook</span><i aria-hidden="true" class="fab fa-facebook-f mono"></i></a><a href="http://twitter.com/Tville_Times" target="_blank" rel="noopener noreferrer"><span class="sr-only">Twitter</span><i aria-hidden="true" class="fab fa-twitter mono"></i></a><a href="http://instagram.com/taylorsvilletimes" target="_blank" rel="noopener noreferrer"><span class="sr-only">Instagram</span><i aria-hidden="true" class="fab fa-instagram mono"></i></a><a href="mailto:news@taylorsvilletimes.com" rel="noopener noreferrer"><span class="sr-only">Email</span><i aria-hidden="true" class="fas fa-envelope mono"></i></a></div> </div> </div> </div> </div> </div> <div class="fl-page"> <header class="fl-page-header fl-page-header-primary fl-page-nav-bottom fl-page-nav-toggle-button fl-page-nav-toggle-visible-mobile" itemscope="itemscope" itemtype="http://schema.org/WPHeader"> <div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="col-md-8 col-sm-8"> <div class="fl-page-header-logo" itemscope="itemscope" itemtype="http://schema.org/Organization"> <a href="https://www.taylorsvilletimes.com" itemprop="url"><img loading="false" data-no-lazy="1" class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="http://www.taylorsvilletimes.com/wp-content/uploads/2016/09/Taylorsville-Times-Banner.jpg" data-retina="" title="" alt="The Taylorsville Times" /><meta itemprop="name" content="The Taylorsville Times" /></a> </div> </div> <div class="col-md-4 col-sm-4"> <div class="fl-page-header-content"> <div id="webads_weather_widget-2" class="widget widget_webads_weather_widget pull-right">  <div id="webads-weather-28681" class="widget widget-webads-weather"> <a id="webads-weather-28681-link" href="https://www.taylorsvilletimes.com"> <div class="awe-mini"> <div> <div class="col visual"> <span id="webads-weather-28681-temperature" class="temperature"></span> <i id="webads-weather-28681-image" class="weather-forecast-icon" style="background-size:contain"></i> </div> <div class="col info"> <span id="webads-weather-28681-location" class="location"></span> <span id="webads-weather-28681-conditions" class="forecast"></span> </div> </div> </div> </a> </div>  </div><div id="search-2" class="widget widget_search pull-right"><form aria-label="Search" method="get" role="search" action="https://www.taylorsvilletimes.com/" title="Type and press Enter to search."> <input aria-label="Search" type="search" class="fl-search-input form-control" name="s" placeholder="Search" value="" onfocus="if (this.value === 'Search') { this.value = ''; }" onblur="if (this.value === '') this.value='Search';" /> </form> </div><div id="execphp-2" class="widget widget_execphp pull-right"> <div class="execphpwidget">November 29, 2021</div> </div> </div> </div> </div> </div> </div> <div class="fl-page-nav-wrap"> <div class="fl-page-nav-container container"> <nav class="fl-page-nav navbar navbar-default" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span>Menu</span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-main-menu" class="nav navbar-nav menu"><li id="menu-item-1076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-has-children menu-item-1076 nav-item"><a href="https://www.taylorsvilletimes.com/" class="nav-link">Home</a> <ul class="sub-menu"> <li id="menu-item-24448" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24448 nav-item"><a href="https://www.taylorsvilletimes.com/category/breaking-news/" class="nav-link">Breaking News</a></li> <li id="menu-item-766" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-766 nav-item"><a href="https://www.taylorsvilletimes.com/category/sports/" class="nav-link">Sports</a></li> <li id="menu-item-24446" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-24446 nav-item"><a href="#" class="nav-link">Connect</a> <ul class="sub-menu"> <li id="menu-item-23828" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23828 nav-item"><a href="https://www.taylorsvilletimes.com/advertising-rates/" class="nav-link">Advertising Rates</a></li> <li id="menu-item-23425" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-23425 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://taylorsvillenc.ors.kwnews.com/" class="nav-link">Church Directory</a> <ul class="sub-menu"> <li id="menu-item-23426" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23426 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://taylorsvillenc.ors.kwnews.com/page" class="nav-link">Church of the Week</a></li> </ul> </li> <li id="menu-item-289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-289 nav-item"><a href="https://www.taylorsvilletimes.com/crossword/" class="nav-link">Crossword</a></li> <li id="menu-item-23434" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23434 nav-item"><a href="https://www.taylorsvilletimes.com/meet-us-on-social-media/" class="nav-link">Social media &#038; Our Podcast</a></li> <li id="menu-item-290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-290 nav-item"><a href="https://www.taylorsvilletimes.com/event-calendar/" class="nav-link">Events</a></li> <li id="menu-item-293" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-293 nav-item"><a href="https://www.taylorsvilletimes.com/photos/" class="nav-link">Photos</a></li> <li id="menu-item-46641" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46641 nav-item"><a href="https://www.taylorsvilletimes.com/public-forum/" class="nav-link">Public Forum</a></li> <li id="menu-item-23832" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23832 nav-item"><a href="https://www.taylorsvilletimes.com/times-history/" class="nav-link">Times’ History</a></li> <li id="menu-item-23435" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23435 nav-item"><a href="https://www.taylorsvilletimes.com/where-to-buy-the-times/" class="nav-link">Where To Buy The Times</a></li> </ul> </li> </ul> </li> <li id="menu-item-43221" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43221 nav-item"><a href="https://www.taylorsvilletimes.com/obituaries/" class="nav-link">Obituaries</a></li> <li id="menu-item-296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-296 nav-item"><a href="#" class="nav-link">E-Editions</a> <ul class="sub-menu"> <li id="menu-item-24389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24389 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=ebf2cc70-aaa6-40ab-ac88-1de546069d6d" class="nav-link">The Taylorsville Times</a></li> <li id="menu-item-24388" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24388 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=4b944019-7f68-4c98-beee-fd6f2e06aaaa" class="nav-link">The Bethlehem Star</a></li> <li id="menu-item-246558" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-246558 nav-item"><a href="https://www.taylorsvilletimes.com/2020/03/05/why-i-love-alexander-county-an-essay-series/" class="nav-link">&#8220;I Love Alexander&#8221; Essays</a></li> <li id="menu-item-24387" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24387 nav-item"><a target="_blank" rel="noopener noreferrer" href="https://www.newstogo.us/editionviewer/default.aspx?Publication=fced17f6-97f1-4d30-9c1f-2b478c0f1936&#038;view=archives" class="nav-link">Special Sections</a></li> <li id="menu-item-42416" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-42416 nav-item"><a href="#" class="nav-link">Archives</a> <ul class="sub-menu"> <li id="menu-item-42417" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42417 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?view=archives&#038;Edition=4347a18b-eb96-4d2a-af00-10bd5e75bba0" class="nav-link">The Taylorsville Times</a></li> <li id="menu-item-42418" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42418 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?view=archives&#038;Edition=1bb6cacb-0050-467b-abea-88afc18c2e90" class="nav-link">The Bethlehem Star</a></li> </ul> </li> </ul> </li> <li id="menu-item-249508" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249508 nav-item"><a href="https://www.taylorsvilletimes.com/2021/11/23/legal-notices-2/" class="nav-link">LEGAL NOTICES</a></li> <li id="menu-item-24179" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-24179 nav-item"><a href="https://www.taylorsvilletimes.com/category/classifieds/" class="nav-link">Classifieds</a> <ul class="sub-menu"> <li id="menu-item-249509" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249509 nav-item"><a href="https://www.taylorsvilletimes.com/2021/11/23/automotive/" class="nav-link">AUTOMOTIVE</a></li> <li id="menu-item-249510" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249510 nav-item"><a href="https://www.taylorsvilletimes.com/2021/11/23/for-rent-12/" class="nav-link">FOR RENT</a></li> <li id="menu-item-249511" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249511 nav-item"><a href="https://www.taylorsvilletimes.com/2021/11/23/for-sale-2/" class="nav-link">FOR SALE</a></li> <li id="menu-item-252918" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-252918 nav-item"><a href="https://www.taylorsvilletimes.com/2021/11/23/free-2/" class="nav-link">FREE</a></li> <li id="menu-item-249512" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249512 nav-item"><a href="https://www.taylorsvilletimes.com/2021/11/23/general-4/" class="nav-link">GENERAL</a></li> <li id="menu-item-249513" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249513 nav-item"><a href="https://www.taylorsvilletimes.com/2021/11/23/help-wanted-9/" class="nav-link">HELP WANTED</a></li> <li id="menu-item-249514" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249514 nav-item"><a href="https://www.taylorsvilletimes.com/2021/11/23/wanted/" class="nav-link">WANTED</a></li> <li id="menu-item-252930" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-252930 nav-item"><a href="https://www.taylorsvilletimes.com/2021/11/23/yard-sale-6/" class="nav-link">YARD SALE</a></li> <li id="menu-item-24137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24137 nav-item"><a href="https://www.taylorsvilletimes.com/submit-a-classified/" class="nav-link">Submit a Classified</a></li> </ul> </li> <li id="menu-item-23818" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-23818 nav-item"><a href="#" class="nav-link">Weekly Circulars</a> <ul class="sub-menu"> <li id="menu-item-252914" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252914 nav-item"><a target="_blank" rel="noopener noreferrer" href="https://www.academy.com/" class="nav-link">Academy Sports + Outdoors</a></li> <li id="menu-item-252916" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252916 nav-item"><a target="_blank" rel="noopener noreferrer" href="https://www.acehardware.com/store-details/16960" class="nav-link">Bethlehem Ace Hardware &#038; Hallmark</a></li> <li id="menu-item-252917" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252917 nav-item"><a target="_blank" rel="noopener noreferrer" href="https://www.burkesoutlet.com/" class="nav-link">Burkes Outlet</a></li> <li id="menu-item-23819" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23819 nav-item"><a target="_blank" rel="noopener noreferrer" href="https://www.foodlion.com/weekly-specials/" class="nav-link">Food Lion</a></li> <li id="menu-item-252915" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252915 nav-item"><a target="_blank" rel="noopener noreferrer" href="https://www.tractorsupply.com/" class="nav-link">Tractor Supply Co.</a></li> </ul> </li> <li id="menu-item-244238" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-244238 nav-item"><a href="https://www.taylorsvilletimes.com/business-service-directory/" class="nav-link">Business Directory</a></li> </ul> </div> </nav> </div> </div> </header> <div class="fl-page-content" itemprop="mainContentOfPage"> <div class="webads-userbar-wrapper" style="display: none;"><span class="webads-userbar"><span class="webads-userbar-name"></span><span class="fl-sep"> | </span><a href="https://www.taylorsvilletimes.com/wp-admin/admin-post.php?action=webads_logout&webads_logout_nonce=DS9URN7DtQcxre6U"><span>logout</span></a></span></div>  <div class="container"> <div class="row"> <div class="fl-content fl-content-left col-md-9"> <article class="fl-post post-252943 post type-post status-publish format-standard has-post-thumbnail hentry category-obituaries" id="fl-post-252943" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <header class="fl-post-header"> <h1 class="fl-post-title" itemprop="headline"> Lonnie Eugene Vickers </h1> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person">By <a href="https://www.taylorsvilletimes.com/author/editor/" itemprop="url"><span itemprop="name">Editor</span></a></span><span class="fl-sep"> | </span><span class="fl-post-date" itemprop="datePublished" datetime="2021-11-26">November 26, 2021</span><span class="fl-sep"> | </span><span class="fl-comments-popup-link"><a href="https://www.taylorsvilletimes.com/2021/11/26/lonnie-eugene-vickers/#respond" tabindex="-1" aria-hidden="true">0 <i class="fa fa-comment"></i></a></span></div><meta itemprop="image" content="https://www.taylorsvilletimes.com/wp-content/uploads/2021/11/Lonnie-Vickers-1.jpg"><meta itemprop="interactionCount" content="UserComments:0"> </header> <div class="fl-post-content clearfix" itemprop="text"> <div id="attachment_252938" style="width: 313px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-252938" loading="lazy" class=" wp-image-252938" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/11/Lonnie-Vickers-1-257x300.jpg" alt="" width="303" height="354" srcset="https://www.taylorsvilletimes.com/wp-content/uploads/2021/11/Lonnie-Vickers-1-257x300.jpg 257w, https://www.taylorsvilletimes.com/wp-content/uploads/2021/11/Lonnie-Vickers-1-876x1024.jpg 876w, https://www.taylorsvilletimes.com/wp-content/uploads/2021/11/Lonnie-Vickers-1-768x898.jpg 768w, https://www.taylorsvilletimes.com/wp-content/uploads/2021/11/Lonnie-Vickers-1.jpg 1026w" sizes="(max-width: 303px) 100vw, 303px" /><p id="caption-attachment-252938" class="wp-caption-text">Lonnie Eugene Vickers</p></div> <p>Lonnie Eugene Vickers, age 67, of Hickory, passed away on Friday, November 26, 2021, at his home.</p> <p>Lonnie was born November 29, 1953, in Wilkes County, the son of the late Bill Vickers and Katie Marie Parsons Vickers. He attended Pleasant Grove Baptist Church in Wilkesboro as a youth.</p> <p>Including his parents, he was preceded in death by a brother, Billy Wayne Vickers.</p> <p>Those left to cherish his memory include a daughter, Valerie Vickers-Robinson (Fred) of Millers Creek; a son, Justin Brian Vickers (Amanda Kay) of Wilkesboro; grandchildren, Ethan Tate Robinson, Holly Noelle Robinson, Hayden Eric Vickers, and Hannah Kay Vickers; and a brother, Lanie Vickers of Millers Creek.</p> <p>No services are planned at this time.</p> <p>Condolences may be sent to www.adamsfunerals.com.</p> <p>Adams Funeral Home and Cremation Services is honored to be serving the family of Lonnie Eugene Vickers.</p> <div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.taylorsvilletimes.com/2021/11/26/lonnie-eugene-vickers/" data-a2a-title="Lonnie Eugene Vickers"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F11%2F26%2Flonnie-eugene-vickers%2F&amp;linkname=Lonnie%20Eugene%20Vickers" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F11%2F26%2Flonnie-eugene-vickers%2F&amp;linkname=Lonnie%20Eugene%20Vickers" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_printfriendly" href="https://www.addtoany.com/add_to/printfriendly?linkurl=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F11%2F26%2Flonnie-eugene-vickers%2F&amp;linkname=Lonnie%20Eugene%20Vickers" title="PrintFriendly" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div> </div> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags">Posted in <a href="https://www.taylorsvilletimes.com/category/obituaries/" rel="category tag">Obituaries</a></div></div> <div class="fl-comments"> <div id="respond"> <h3 class="fl-comments-respond-title">Leave a Comment</h3> <form class="fl-comment-form" action="https://www.taylorsvilletimes.com/wp-comments-post.php" method="post"> <label for="author">Name (required)</label> <input type="text" name="author" class="form-control" value="" tabindex="1" aria-required='true' /> <br/> <label for="email">Email (will not be published) (required)</label> <input type="text" name="email" class="form-control" value="" tabindex="2" aria-required='true' /> <br/> <label for="comment">Comment</label> <textarea name="comment" class="form-control" cols="60" rows="8" tabindex="4"></textarea> <br/> <div class="g-recaptcha" data-sitekey="6LdvRcMZAAAAAEXIplzSR6ZvSkSZTV1inA8BbwkV"></div> <br> <input name="submit" type="submit" class="btn btn-primary" tabindex="5" value="Submit Comment"/> <input type='hidden' name='comment_post_ID' value='252943' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /> <input type="hidden" id="ct_checkjs_a8f15eda80c50adb0e71943adc8015cf" name="ct_checkjs" value="0" /> <div class="fl-comment-form-cancel"> <a rel="nofollow" id="cancel-comment-reply-link" href="/2021/11/26/lonnie-eugene-vickers/#respond" style="display:none;">Click here to cancel reply.</a> </div> </form> </div> </div> <style>
                    .fl-post-featured-post {
                        border-bottom: 1px solid #e6e6e6;
                        margin-bottom: 10px;
                        padding-bottom: 0px;
                        margin-left: 20px;
                    }

                    .fl-post-featured-image-beside .fl-post-featured-image {
                        float: left;
                        width: 120px;
                        padding-right: 5px;
                    }

                    .fl-clear {
                        clear: both;
                    }

                    h5.fl-post-featured-title {
                        margin: 0 0 10px;
                        padding: 0;
                        font-weight: bold;
                    }

                    .fl-post-featured-image {
                        margin-bottom: 10px;
                    }

                    .fl-post-featured-image img {
                        height: auto !important;
                        width: 100% !important;
                    }

                    .fl-post-featured-header {
                        margin-bottom: 15px;
                    }

                </style> <div id="webads-related-posts"> <h3>Related Posts</h3> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/11/25/geraldine-gerri-combs-benfield/" rel="bookmark" title="Geraldine “Gerri” Combs Benfield"> <img width="221" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/11/Geraldine-Benfield-1637929693-e1638208541388-221x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/11/25/geraldine-gerri-combs-benfield/" rel="bookmark" title="Geraldine “Gerri” Combs Benfield">Geraldine “Gerri” Combs Benfield</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> November 25, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/11/25/geraldine-gerri-combs-benfield/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/11/24/steven-stevie-mark-gilliam/" rel="bookmark" title="Steven “Stevie” Mark Gilliam"> <img width="181" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/11/Steven-Mark-Gilliam-e1638208671957-181x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/11/24/steven-stevie-mark-gilliam/" rel="bookmark" title="Steven “Stevie” Mark Gilliam">Steven “Stevie” Mark Gilliam</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> November 24, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/11/24/steven-stevie-mark-gilliam/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/11/18/hazel-daniels-hoyle/" rel="bookmark" title="Hazel Daniels Hoyle"> <img width="195" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/11/Hazel-Hoyle-pic-e1637611273371-195x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/11/18/hazel-daniels-hoyle/" rel="bookmark" title="Hazel Daniels Hoyle">Hazel Daniels Hoyle</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> November 18, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/11/18/hazel-daniels-hoyle/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/11/16/steve-wayne-fox/" rel="bookmark" title="Steve Wayne Fox"> <img width="191" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/11/Steve-Fox-1-e1637098012969-191x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/11/16/steve-wayne-fox/" rel="bookmark" title="Steve Wayne Fox">Steve Wayne Fox</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> November 16, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/11/16/steve-wayne-fox/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/11/16/troy-clyde-watts-jr/" rel="bookmark" title="Troy Clyde Watts, Jr."> <img width="172" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/11/Troy-Watts-e1637095085615-172x300.jpeg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/11/16/troy-clyde-watts-jr/" rel="bookmark" title="Troy Clyde Watts, Jr.">Troy Clyde Watts, Jr.</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> November 16, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/11/16/troy-clyde-watts-jr/#comments" tabindex="-1" aria-hidden="true">1 Comment »</a></span> </div> </div> <div class="fl-clear"></div> </div> </div> </article> </div> <div class="fl-sidebar fl-sidebar-right fl-sidebar-display-always col-md-3" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"> <aside id="adrotate_widgets-2" class="fl-widget widget_adrotate_widgets"><div class="g g-1"><div class="g-dyn a-3 c-1"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Adams Funeral Home - Spotlight', 1.00, {'nonInteraction': 1});" href="http://www.adamsfunerals.com" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Adams Funeral Home - Spotlight', 2.00, {'nonInteraction': 1});" src="http://www.taylorsvilletimes.com/wp-content/uploads/2017/01/Adams-Funeral-BC-2017.jpg" /></a></div><div class="g-dyn a-18 c-2"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Jobs', 1.00, {'nonInteraction': 1});" href="http://www.hometownemploymentnetwork.com/default.aspx?affiliateid=1137" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Jobs', 2.00, {'nonInteraction': 1});" src="http://www.taylorsvilletimes.com/wp-content/uploads/2016/09/jobs.jpg" /></a></div><div class="g-dyn a-43 c-3"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Alexander Funeral', 1.00, {'nonInteraction': 1});" href="http://alexfuneralservice.com" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Alexander Funeral', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/09/AF-Business-Card-for-website-1.jpg" /></a></div><div class="g-dyn a-26 c-4"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Service Directory', 1.00, {'nonInteraction': 1});" href="https://www.taylorsvilletimes.com/business-service-directory/"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Service Directory', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2017/08/Service-Directory-BC-for-web-2017.jpg" /></a></div></div></aside><aside id="adrotate_widgets-3" class="fl-widget widget_adrotate_widgets"><div class="a-single a-10"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Breaking News Signup', 1.00, {'nonInteraction': 1});" href="http://www.taylorsvilletimes.com/breaking-news-signup/"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Breaking News Signup', 2.00, {'nonInteraction': 1});" src="http://www.taylorsvilletimes.com/wp-content/uploads/2016/10/breakingNewsHeader.png" /></a></div></aside><aside id="polls-widget-2" class="fl-widget widget_polls-widget"><h4 class="fl-widget-title">Online Poll</h4>Sorry, there are no polls available at the moment.<ul><li><a href="http://www.taylorsvilletimes.com/pollsarchive">Polls Archive</a></li></ul></aside><aside id="webads_displayads_widget-2" class="fl-widget widget_webads_displayads_widget"> <style>
                    #displayAds img {
                        width: 100%;
                        height: auto;
                    }

                                        #displayAdsWrapper {
                        height: 1500px;
                        overflow: hidden;
                    }
                    

                </style> <div id="displayAdsWrapper"> <div id="displayAds"> <ul id="displayAdsUL"> </ul> </div> </div>  <div id="displayAdDirLink"><h3><a href="https://www.taylorsvilletimes.com/1709/advertiser-directory">View All Advertisers</h3></div></aside> </div> </div> </div> </div> </div> <footer class="fl-page-footer-wrap" itemscope="itemscope" itemtype="http://schema.org/WPFooter"> <div class="fl-page-footer-widgets"> <div class="fl-page-footer-widgets-container container"> <div class="fl-page-footer-widgets-row row"> <div class="col-sm-4 col-md-4 fl-page-footer-widget-col fl-page-footer-widget-col-1"><aside id="nav_menu-3" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">The Taylorsville Times</h4><div class="menu-footer-menu-1-container"><ul id="menu-footer-menu-1" class="menu"><li id="menu-item-228" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-228"><a href="http://www.taylorsvilletimes.com/">Home</a></li> <li id="menu-item-229" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-229"><a href="https://www.taylorsvilletimes.com/contact-us/">Contact Us</a></li> <li id="menu-item-24392" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24392"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=ebf2cc70-aaa6-40ab-ac88-1de546069d6d">The Taylorsville Times</a></li> <li id="menu-item-24391" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24391"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=4b944019-7f68-4c98-beee-fd6f2e06aaaa">The Bethlehem Star</a></li> <li id="menu-item-24390" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24390"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=fced17f6-97f1-4d30-9c1f-2b478c0f1936">125th Anniversary Edition</a></li> <li id="menu-item-231" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-231"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=ebf2cc70-aaa6-40ab-ac88-1de546069d6d&#038;view=subscribe">Subscribe</a></li> <li id="menu-item-23835" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23835"><a href="https://www.taylorsvilletimes.com/copyright/">Copyright</a></li> <li id="menu-item-23836" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23836"><a href="https://www.taylorsvilletimes.com/times-history/">Times&#8217; History</a></li> <li id="menu-item-23837" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23837"><a href="https://www.taylorsvilletimes.com/advertising-rates/">Advertising Rates</a></li> <li id="menu-item-23839" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23839"><a href="https://www.taylorsvilletimes.com/where-to-buy-the-times/">Where To Buy The Times</a></li> </ul></div></aside></div><div class="col-sm-4 col-md-4 fl-page-footer-widget-col fl-page-footer-widget-col-2"><aside id="webads_syndicated_stories_menu_widget-2" class="fl-widget widget_webads_syndicated_stories_menu_widget"><h4 class="fl-widget-title">US &#038; World News</h4> <div><ul class="menu"> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/united-states/">US</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/sports/">Sports</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/entertainment/">Entertainment</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/technology/">Technology</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/political/">Politics</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/world/">World</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/business/">Business</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/health/">Health</a></li> </ul></div> </aside></div><div class="col-sm-4 col-md-4 fl-page-footer-widget-col fl-page-footer-widget-col-3"><aside id="nav_menu-5" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">Odds &#038; Ends</h4><div class="menu-footer-menu-3-container"><ul id="menu-footer-menu-3" class="menu"><li id="menu-item-216" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-216"><a href="https://www.taylorsvilletimes.com/crossword/">Crossword Puzzle</a></li> <li id="menu-item-217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-217"><a href="https://www.taylorsvilletimes.com/event-calendar/">Event Calendar</a></li> <li id="menu-item-1473" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1473"><a href="https://www.taylorsvilletimes.com/poll/">Online Poll</a></li> <li id="menu-item-218" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218"><a href="https://www.taylorsvilletimes.com/photos/">Photo Galleries</a></li> <li id="menu-item-23840" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23840"><a href="https://www.taylorsvilletimes.com/meet-us-on-social-media/">Meet us on social media</a></li> </ul></div></aside></div> </div> </div> </div> <div class="fl-page-footer"> <div class="fl-page-footer-container container"> <div class="fl-page-footer-row row"> <div class="col-md-12 text-center clearfix"><div class="fl-page-footer-text fl-page-footer-text-1">This website is powered by <a href="http://www.websitesfornewspapers.com" target="_blank"><i><strong>WebsitesForNewspapers.com</strong></i></a></div></div> </div> </div> </div> </footer>               
</body></html>
<!--
Cached page generated by Borlabs Cache - more information https://borlabs.io/
Time to create cache: 2.1282661 sec
Time to load cache: 0.45358896
Cache file created on: 2021-11-29T18:01:22+00:00
Current time: 2021-11-29T19:17:28+00:00
-->