<!DOCTYPE html> <html lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml"> <head><link rel="dns-prefetch" href="//ajax.googleapis.com">
<link rel="dns-prefetch" href="//www.google.com">
<link rel="dns-prefetch" href="//fonts.googleapis.com">
<link rel="preload" href="https://www.taylorsvilletimes.com/wp-content/cache/borlabs_cache/1/js/bd12da51a435779dbec116e77a343c51512153a7_https.js" as="script">
<link rel="preload" href="https://www.taylorsvilletimes.com/wp-content/cache/borlabs_cache/1/css/01631d7776f7e05efb28006d661f2559be1f01b0_https.css" as="style">
<link rel="stylesheet" href="https://www.taylorsvilletimes.com/wp-content/cache/borlabs_cache/1/css/01631d7776f7e05efb28006d661f2559be1f01b0_https.css" type="text/css" media="all"><link href="https://fonts.googleapis.com/css?family=Oswald%3A400" rel="stylesheet"> <meta charset="UTF-8" /> <meta name="viewport" content="width=device-width, initial-scale=1.0" /> <meta http-equiv="X-UA-Compatible" content="IE=edge" /> <link rel="profile" href="https://gmpg.org/xfn/11" /> <link rel="pingback" href="https://www.taylorsvilletimes.com/xmlrpc.php" />   <!--[if lt IE 9]> <script src="https://www.taylorsvilletimes.com/wp-content/themes/bb-theme/js/html5shiv.js"></script> <script src="https://www.taylorsvilletimes.com/wp-content/themes/bb-theme/js/respond.min.js"></script> <![endif]--> <title>Alex. native is new director of NJ’s largest municipal library system &#8211; The Taylorsville Times</title>  <link rel='dns-prefetch' href='//ajax.googleapis.com' /> <link rel='dns-prefetch' href='//www.google.com' /> <link rel="alternate" type="application/rss+xml" title="The Taylorsville Times &raquo; Feed" href="https://www.taylorsvilletimes.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="The Taylorsville Times &raquo; Comments Feed" href="https://www.taylorsvilletimes.com/comments/feed/" /> <link rel="alternate" type="application/rss+xml" title="The Taylorsville Times &raquo; Alex. native is new director of NJ’s largest municipal library system Comments Feed" href="https://www.taylorsvilletimes.com/2021/08/18/alex-native-is-new-director-of-njs-largest-municipal-library-system/feed/" /> <meta property="og:title" content="Alex. native is new director of NJ’s largest municipal library system"/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.taylorsvilletimes.com/2021/08/18/alex-native-is-new-director-of-njs-largest-municipal-library-system/"/><meta property="og:site_name" content="The Taylorsville Times"/><meta property="og:image" content="https://www.taylorsvilletimes.com/wp-content/uploads/2021/08/Terry-B-Hill-copy-e1629320373628.jpg"/>                      <style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 8px;
	line-height: 10px;
	height: 10px;
	background-image: url('https://www.taylorsvilletimes.com/wp-content/plugins/webads-polls/images/default_gradient/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>                                                        <link rel="https://api.w.org/" href="https://www.taylorsvilletimes.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.taylorsvilletimes.com/wp-json/wp/v2/posts/252016" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.taylorsvilletimes.com/xmlrpc.php?rsd" /> <link rel='prev' title='Martha Joel Childers Hammer' href='https://www.taylorsvilletimes.com/2021/08/16/martha-joel-childers-hammer/' /> <link rel='next' title='Tornadoes cause scare, little damage on Aug. 17' href='https://www.taylorsvilletimes.com/2021/08/18/tornadoes-cause-scare-little-damage-on-aug-17/' /> <link rel="canonical" href="https://www.taylorsvilletimes.com/2021/08/18/alex-native-is-new-director-of-njs-largest-municipal-library-system/" /> <link rel='shortlink' href='https://www.taylorsvilletimes.com/?p=252016' /> <link rel="alternate" type="application/json+oembed" href="https://www.taylorsvilletimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F08%2F18%2Falex-native-is-new-director-of-njs-largest-municipal-library-system%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://www.taylorsvilletimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F08%2F18%2Falex-native-is-new-director-of-njs-largest-municipal-library-system%2F&#038;format=xml" />  <style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:175px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>  <link rel="shortcut icon" href="https://www.taylorsvilletimes.com/wp-content/uploads/2021/03/favicon-16x16-1.png"/>  <style id="fl-theme-custom-css">.widget_execphp {
    font-weight: bold;
    padding-top: 20px;
}</style> <script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js?ver=1.12.4' id='jquery-js'></script><script type='text/javascript' src='https://www.google.com/recaptcha/api.js?ver=5.5.5' id='recaptcha-scripts-js'></script><script type="text/javascript" src="https://www.taylorsvilletimes.com/wp-content/cache/borlabs_cache/1/js/bd12da51a435779dbec116e77a343c51512153a7_https.js"></script></head> <body class="post-template-default single single-post postid-252016 single-format-standard ecwd-theme-parent-bb-theme ecwd-theme-child-bb-theme-child fl-preset-color01 fl-fixed-width" itemscope="itemscope" itemtype="http://schema.org/WebPage"> <div> <div class="fl-page-bar"> <div class="fl-page-bar-container container"> <div class="fl-page-bar-row row"> <div class="col-md-8 hidden-sm text-left clearfix"> <div class="breakingNews" id="bn7"> <div class="bn-title"><h2>Breaking News</h2><span></span></div> <ul> <li><a href="https://www.taylorsvilletimes.com/2021/08/18/readers-choice-chance-to-win-50-by-filling-out-survey/">Readers&#8217; Choice: Chance to win $50 by filling out survey</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/08/18/governor-provides-update-on-pandemic/">Governor provides update on pandemic</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/08/18/tornadoes-cause-scare-little-damage-on-aug-17/">Tornadoes cause scare, little damage on Aug. 17</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/08/18/alex-native-is-new-director-of-njs-largest-municipal-library-system/">Alex. native is new director of NJ’s largest municipal library system</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/08/13/free-concert-aug-13/">Free Concert Aug. 13</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/08/11/plane-comes-down-in-field/">Plane comes down in field</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/08/11/vietnam-veterans-honored-in-ceremony/">Vietnam Veterans honored in ceremony</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/08/09/over-200-new-covid-cases-in-past-2-weeks/">Over 200 new COVID cases in past 2 weeks</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/08/09/school-board-to-meet-august-10/">School Board to meet August 10</a></li> <li><a href="https://www.taylorsvilletimes.com/2021/08/09/courthouse-a-c-repairs-slated-for-aug-10/">Courthouse A/C repairs slated for Aug. 10</a></li> </ul> <div class="bn-navi"> <span></span> <span></span> </div> </div>  <div class="fl-page-bar-text fl-page-bar-text-1"></div></div> <div class="col-md-4 col-sm-12 text-right clearfix"><ul class="fl-page-bar-nav nav navbar-nav menu"><li><a href="https://www.taylorsvilletimes.com">Home</a></li></ul><div class="fl-social-icons"><a href="https://www.facebook.com/taylorsvilletimes" target="_blank" class="fl-icon fl-icon-color-mono fl-icon-facebook fl-icon-facebook-regular"></a><a href="https://twitter.com/Tville_Times" target="_blank" class="fl-icon fl-icon-color-mono fl-icon-twitter fl-icon-twitter-regular"></a><a href="https://instagram.com/taylorsvilletimes" target="_blank" class="fl-icon fl-icon-color-mono fl-icon-instagram fl-icon-instagram-regular"></a><a href="/cdn-cgi/l/email-protection#bad4dfcdc9facedbc3d6d5c8c9ccd3d6d6dfced3d7dfc994d9d5d7" class="fl-icon fl-icon-color-mono fl-icon-email fl-icon-email-regular"></a></div></div> </div> </div> </div></div> <div class="fl-page"> <header class="fl-page-header fl-page-header-primary fl-page-nav-bottom fl-page-nav-toggle-button" itemscope="itemscope" itemtype="http://schema.org/WPHeader"> <div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="col-md-8 col-sm-8"> <div class="fl-page-header-logo" itemscope="itemscope" itemtype="http://schema.org/Organization"> <a href="https://www.taylorsvilletimes.com" itemprop="url"><img class="fl-logo-img" itemscope itemtype="http://schema.org/ImageObject" src="https://www.taylorsvilletimes.com/wp-content/uploads/2016/09/Taylorsville-Times-Banner.jpg" data-retina="" alt="The Taylorsville Times" /><meta itemprop="name" content="The Taylorsville Times" /></a> </div> </div> <div class="col-md-4 col-sm-4"> <div class="fl-page-header-content"> <div id="webads_weather_widget-2" class="widget widget_webads_weather_widget pull-right">  <div id="webads-weather-28681" class="widget widget-webads-weather"> <a id="webads-weather-28681-link" href="https://www.taylorsvilletimes.com"> <div class="awe-mini"> <div> <div class="col visual"> <span id="webads-weather-28681-temperature" class="temperature"></span> <i id="webads-weather-28681-image" class="weather-forecast-icon" style="background-size:contain"></i> </div> <div class="col info"> <span id="webads-weather-28681-location" class="location"></span> <span id="webads-weather-28681-conditions" class="forecast"></span> </div> </div> </div> </a> </div>  </div><div id="search-2" class="widget widget_search pull-right"><form method="get" role="search" action="https://www.taylorsvilletimes.com" title="Type and press Enter to search."> <input type="text" class="fl-search-input" name="s" class="form-control" value="Search" onfocus="if (this.value == 'Search') { this.value = ''; }" onblur="if (this.value == '') this.value='Search';"> </form></div><div id="execphp-2" class="widget widget_execphp pull-right"> <div class="execphpwidget">August 18, 2021</div> </div> </div> </div> </div> </div> </div> <div class="fl-page-nav-wrap"> <div class="fl-page-nav-container container"> <nav class="fl-page-nav navbar navbar-default" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span>Menu</span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-main-menu" class="nav navbar-nav menu"><li id="menu-item-1076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-has-children menu-item-1076"><a href="https://www.taylorsvilletimes.com/">Home</a> <ul class="sub-menu"> <li id="menu-item-24448" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-24448"><a href="https://www.taylorsvilletimes.com/category/breaking-news/">Breaking News</a></li> <li id="menu-item-766" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-766"><a href="https://www.taylorsvilletimes.com/category/sports/">Sports</a></li> <li id="menu-item-24446" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-24446"><a href="#">Connect</a> <ul class="sub-menu"> <li id="menu-item-23828" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23828"><a href="https://www.taylorsvilletimes.com/advertising-rates/">Advertising Rates</a></li> <li id="menu-item-23425" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-23425"><a target="_blank" rel="noopener noreferrer" href="http://taylorsvillenc.ors.kwnews.com/">Church Directory</a> <ul class="sub-menu"> <li id="menu-item-23426" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23426"><a target="_blank" rel="noopener noreferrer" href="http://taylorsvillenc.ors.kwnews.com/page">Church of the Week</a></li> </ul> </li> <li id="menu-item-289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-289"><a href="https://www.taylorsvilletimes.com/crossword/">Crossword</a></li> <li id="menu-item-23434" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23434"><a href="https://www.taylorsvilletimes.com/meet-us-on-social-media/">Social media &#038; Our Podcast</a></li> <li id="menu-item-290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-290"><a href="https://www.taylorsvilletimes.com/event-calendar/">Events</a></li> <li id="menu-item-293" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-293"><a href="https://www.taylorsvilletimes.com/photos/">Photos</a></li> <li id="menu-item-46641" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46641"><a href="https://www.taylorsvilletimes.com/public-forum/">Public Forum</a></li> <li id="menu-item-23832" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23832"><a href="https://www.taylorsvilletimes.com/times-history/">Times’ History</a></li> <li id="menu-item-23435" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23435"><a href="https://www.taylorsvilletimes.com/where-to-buy-the-times/">Where To Buy The Times</a></li> </ul> </li> </ul> </li> <li id="menu-item-43221" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43221"><a href="https://www.taylorsvilletimes.com/obituaries/">Obituaries</a></li> <li id="menu-item-296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-296"><a href="#">E-Editions</a> <ul class="sub-menu"> <li id="menu-item-24389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24389"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=ebf2cc70-aaa6-40ab-ac88-1de546069d6d">The Taylorsville Times</a></li> <li id="menu-item-24388" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24388"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=4b944019-7f68-4c98-beee-fd6f2e06aaaa">The Bethlehem Star</a></li> <li id="menu-item-246558" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-246558"><a href="https://www.taylorsvilletimes.com/2020/03/05/why-i-love-alexander-county-an-essay-series/">&#8220;I Love Alexander&#8221; Essays</a></li> <li id="menu-item-24387" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24387"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=fced17f6-97f1-4d30-9c1f-2b478c0f1936">125th Anniversary Edition</a></li> <li id="menu-item-42416" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-42416"><a href="#">Archives</a> <ul class="sub-menu"> <li id="menu-item-42417" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42417"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?view=archives&#038;Edition=4347a18b-eb96-4d2a-af00-10bd5e75bba0">The Taylorsville Times</a></li> <li id="menu-item-42418" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42418"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?view=archives&#038;Edition=1bb6cacb-0050-467b-abea-88afc18c2e90">The Bethlehem Star</a></li> </ul> </li> </ul> </li> <li id="menu-item-249508" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249508"><a href="https://www.taylorsvilletimes.com/2021/08/11/legal-notices-2/">LEGAL NOTICES</a></li> <li id="menu-item-24179" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-24179"><a href="https://www.taylorsvilletimes.com/category/classifieds/">Classifieds</a> <ul class="sub-menu"> <li id="menu-item-249509" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249509"><a href="https://www.taylorsvilletimes.com/2021/08/11/automotive/">AUTOMOTIVE</a></li> <li id="menu-item-249510" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249510"><a href="https://www.taylorsvilletimes.com/2021/08/11/for-rent-12/">FOR RENT</a></li> <li id="menu-item-249511" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249511"><a href="https://www.taylorsvilletimes.com/2021/08/11/for-sale-2/">FOR SALE</a></li> <li id="menu-item-249512" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249512"><a href="https://www.taylorsvilletimes.com/2021/08/11/general-4/">GENERAL</a></li> <li id="menu-item-249513" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249513"><a href="https://www.taylorsvilletimes.com/2021/08/11/help-wanted-9/">HELP WANTED</a></li> <li id="menu-item-249514" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-249514"><a href="https://www.taylorsvilletimes.com/2021/08/11/wanted/">WANTED</a></li> <li id="menu-item-24137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24137"><a href="https://www.taylorsvilletimes.com/submit-a-classified/">Submit a Classified</a></li> </ul> </li> <li id="menu-item-23818" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-23818"><a href="#">Weekly Circulars</a> <ul class="sub-menu"> <li id="menu-item-23819" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23819"><a target="_blank" rel="noopener noreferrer" href="https://www.foodlion.com/weekly-specials/">Food Lion</a></li> </ul> </li> <li id="menu-item-244238" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-244238"><a href="https://www.taylorsvilletimes.com/business-service-directory/">Business Directory</a></li> </ul> </div> </nav> </div> </div> </header> <div class="fl-page-content" itemprop="mainContentOfPage"> <div class="webads-userbar-wrapper" style="display: none;"><span class="webads-userbar"><span class="webads-userbar-name"></span><span class="fl-sep"> | </span><a href="https://www.taylorsvilletimes.com/wp-admin/admin-post.php?action=webads_logout&webads_logout_nonce=DS9URN7DtQcxre6U"><span>logout</span></a></span></div>  <div class="container"> <div class="row"> <div class="fl-content fl-content-left col-md-9"> <article class="fl-post post-252016 post type-post status-publish format-standard has-post-thumbnail hentry category-breaking-news category-news" id="fl-post-252016" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <header class="fl-post-header"> <h1 class="fl-post-title" itemprop="headline"> Alex. native is new director of NJ’s largest municipal library system </h1> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person">By <a href="https://www.taylorsvilletimes.com/author/editor/" itemprop="url"><span itemprop="name">Editor</span></a></span><span class="fl-sep"> | </span><span class="fl-post-date" itemprop="datePublished" datetime="2021-08-18">August 18, 2021</span><span class="fl-sep"> | </span><span class="fl-comments-popup-link"><a href="https://www.taylorsvilletimes.com/2021/08/18/alex-native-is-new-director-of-njs-largest-municipal-library-system/#respond">0 <i class="fa fa-comment"></i></a></span></div><meta itemprop="image" content="https://www.taylorsvilletimes.com/wp-content/uploads/2021/08/Terry-B-Hill-copy-e1629320373628.jpg"><meta itemprop="interactionCount" content="UserComments:0"> </header> <div class="fl-post-content clearfix" itemprop="text"> <div id="attachment_252017" style="width: 372px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-252017" loading="lazy" class="wp-image-252017 size-full" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/08/Terry-B-Hill-copy-e1629320373628.jpg" alt="" width="362" height="458" srcset="https://www.taylorsvilletimes.com/wp-content/uploads/2021/08/Terry-B-Hill-copy-e1629320373628.jpg 362w, https://www.taylorsvilletimes.com/wp-content/uploads/2021/08/Terry-B-Hill-copy-e1629320373628-237x300.jpg 237w" sizes="(max-width: 362px) 100vw, 362px" /><p id="caption-attachment-252017" class="wp-caption-text">Terry B. Hill</p></div> <p><strong>Jersey City, NJ</strong> &#8212; Mayor Steven M. Fulop joins the Board of Directors of the Jersey City Free Public Library (JCFPL) to announce the appointment of Terry B. Hill to the role of Jersey City Library Director effective September 20, according to a press release.</p> <p>Hill is from Taylorsville and graduated from ACHS in 1993. His parents, Junior and Linda Hill, reside in Taylorsville.</p> <p>Hill’s extensive library experience includes notable success in improving digital equity, especially for low-income youth within Durham, North Carolina, where he has served as Deputy Director of Library Services for the past decade.</p> <p>“Terry Hill stood out amongst the impressive applicant pool for his 27 years of successful leadership within urban library systems and establishing strong relationships with the surrounding communities,” said Mayor Fulop, who serves on the JCFPL Board’s search committee. “His knowledge and understanding of issues, trends, and practices of urban library management will be a great asset as he oversees our 10 Library locations citywide, the largest municipal Library system in New Jersey.”</p> <p>“We are delighted to welcome Mr. Hill as the Director of the Jersey City Free Public Library,” said Library Board President Al Anton. “He has a proven track record of effective organizational transformation and forging meaningful relationships with the community, and is enthusiastic to use his depth of skills and knowledge to help continue drive JCFPL forward. We are looking forward to seeing Mr. Hill solidify the Library’s role as a trusted community partner to improve the lives of Jersey City residents.”</p> <p>As the new Library Director, Hill will oversee the entire Jersey City Free Public Library System, which includes 144 experienced and dedicated staff members within the Main Library location, 9 Library branches spanning the City, and a Bookmobile.</p> <p>Hill most recently served as Deputy Director of Library Services at Durham County Library for nearly a decade. Throughout his 27-year career, he has gained substantial experience in the administration of libraries, shaping him into a thoughtful, innovative, and trusted leader.</p> <p>“I look forward to building community partnerships to address issues such as the increasing digital divide,” said Terry Hill. “The past year has highlighted how critical libraries are and how our communities rely on our services.</p> <p>This is a challenging yet exciting time for libraries, and the JCFPL is well-positioned to meet and exceed our community’s needs and expectations.”</p> <p>Hill has served on the Board of Directors for the Durham Literacy Center and the Digital Durham Collaborative, which is a group of community organizations and nonprofits dedicated to addressing the three pillars of digital equity: access to internet service, access to devices, and improving gateway literacy skills.</p> <p>While at Durham County Library, Hill has focused on developing and implementing operations strategies to achieve the mission and vision of the Library. He has been able to bring resources into the Durham County Library via grants, such as a $100,000 grant from the National Institute of Health to provide health literacy and education in the community. Under his leadership, his staff received national recognition for expanding technology services to teens.</p> <p><strong>About Jersey City Free Public Library</strong><br /> The Jersey City Free Public Library has served as a cornerstone of the community since its founding in 1889. With over 130 years of service excellence, the Library remains committed to meeting the demands of its growing and diverse population by keeping pace with the changing interests, trends, and needs. Today, the Jersey City Free Public Library is the largest municipal Library system in New Jersey with 10 locations, a bookmobile, and 144 experienced and dedicated staff members.</p> <div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.taylorsvilletimes.com/2021/08/18/alex-native-is-new-director-of-njs-largest-municipal-library-system/" data-a2a-title="Alex. native is new director of NJ’s largest municipal library system"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F08%2F18%2Falex-native-is-new-director-of-njs-largest-municipal-library-system%2F&amp;linkname=Alex.%20native%20is%20new%20director%20of%20NJ%E2%80%99s%20largest%20municipal%20library%20system" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F08%2F18%2Falex-native-is-new-director-of-njs-largest-municipal-library-system%2F&amp;linkname=Alex.%20native%20is%20new%20director%20of%20NJ%E2%80%99s%20largest%20municipal%20library%20system" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_printfriendly" href="https://www.addtoany.com/add_to/printfriendly?linkurl=https%3A%2F%2Fwww.taylorsvilletimes.com%2F2021%2F08%2F18%2Falex-native-is-new-director-of-njs-largest-municipal-library-system%2F&amp;linkname=Alex.%20native%20is%20new%20director%20of%20NJ%E2%80%99s%20largest%20municipal%20library%20system" title="PrintFriendly" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div> </div> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags">Posted in <a href="https://www.taylorsvilletimes.com/category/breaking-news/" rel="category tag">Breaking News</a>, <a href="https://www.taylorsvilletimes.com/category/news/" rel="category tag">News</a></div></div> <div class="fl-comments"> <div id="respond"> <h3 class="fl-comments-respond-title">Leave a Comment</h3> <form class="fl-comment-form" action="https://www.taylorsvilletimes.com/wp-comments-post.php" method="post"> <label for="author">Name (required)</label> <input type="text" name="author" class="form-control" value="" tabindex="1" aria-required='true' /> <br/> <label for="email">Email (will not be published) (required)</label> <input type="text" name="email" class="form-control" value="" tabindex="2" aria-required='true' /> <br/> <label for="comment">Comment</label> <textarea name="comment" class="form-control" cols="60" rows="8" tabindex="4"></textarea> <br/> <div class="g-recaptcha" data-sitekey="6LdvRcMZAAAAAEXIplzSR6ZvSkSZTV1inA8BbwkV"></div> <br> <input name="submit" type="submit" class="btn btn-primary" tabindex="5" value="Submit Comment"/> <input type='hidden' name='comment_post_ID' value='252016' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /> <input type="hidden" id="ct_checkjs_aa169b49b583a2b5af89203c2b78c67c" name="ct_checkjs" value="0" /> <div class="fl-comment-form-cancel"> <a rel="nofollow" id="cancel-comment-reply-link" href="/2021/08/18/alex-native-is-new-director-of-njs-largest-municipal-library-system/#respond" style="display:none;">Click here to cancel reply.</a> </div> </form> </div> </div> <style>
                    .fl-post-featured-post {
                        border-bottom: 1px solid #e6e6e6;
                        margin-bottom: 10px;
                        padding-bottom: 0px;
                        margin-left: 20px;
                    }

                    .fl-post-featured-image-beside .fl-post-featured-image {
                        float: left;
                        width: 120px;
                        padding-right: 5px;
                    }

                    .fl-clear {
                        clear: both;
                    }

                    h5.fl-post-featured-title {
                        margin: 0 0 10px;
                        padding: 0;
                        font-weight: bold;
                    }

                    .fl-post-featured-image {
                        margin-bottom: 10px;
                    }

                    .fl-post-featured-image img {
                        height: auto !important;
                        width: 100% !important;
                    }

                    .fl-post-featured-header {
                        margin-bottom: 15px;
                    }

                </style> <div id="webads-related-posts"> <h3>Related Posts</h3> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/08/18/readers-choice-chance-to-win-50-by-filling-out-survey/" rel="bookmark" title="Readers&#8217; Choice: Chance to win $50 by filling out survey"> <img width="300" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/08/Readers-Choice-teaser-2021-sq-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" srcset="https://www.taylorsvilletimes.com/wp-content/uploads/2021/08/Readers-Choice-teaser-2021-sq-300x300.jpg 300w, https://www.taylorsvilletimes.com/wp-content/uploads/2021/08/Readers-Choice-teaser-2021-sq.jpg 534w" sizes="(max-width: 300px) 100vw, 300px" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/08/18/readers-choice-chance-to-win-50-by-filling-out-survey/" rel="bookmark" title="Readers&#8217; Choice: Chance to win $50 by filling out survey">Readers&#8217; Choice: Chance to win $50 by filling out survey</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> August 18, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/08/18/readers-choice-chance-to-win-50-by-filling-out-survey/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/08/18/governor-provides-update-on-pandemic/" rel="bookmark" title="Governor provides update on pandemic"> <img width="300" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2020/10/Cooper-Apr15-EVFkdiHU0AUpd0E-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/08/18/governor-provides-update-on-pandemic/" rel="bookmark" title="Governor provides update on pandemic">Governor provides update on pandemic</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> August 18, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/08/18/governor-provides-update-on-pandemic/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/08/18/tornadoes-cause-scare-little-damage-on-aug-17/" rel="bookmark" title="Tornadoes cause scare, little damage on Aug. 17"> <img width="300" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/08/IMG_4725-copy-e1629320625146-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/08/18/tornadoes-cause-scare-little-damage-on-aug-17/" rel="bookmark" title="Tornadoes cause scare, little damage on Aug. 17">Tornadoes cause scare, little damage on Aug. 17</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> August 18, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/08/18/tornadoes-cause-scare-little-damage-on-aug-17/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/08/13/free-concert-aug-13/" rel="bookmark" title="Free Concert Aug. 13"> <img width="300" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/08/Shakedown-post-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/08/13/free-concert-aug-13/" rel="bookmark" title="Free Concert Aug. 13">Free Concert Aug. 13</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> August 13, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/08/13/free-concert-aug-13/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.taylorsvilletimes.com/2021/08/11/plane-comes-down-in-field/" rel="bookmark" title="Plane comes down in field"> <img width="300" height="300" src="https://www.taylorsvilletimes.com/wp-content/uploads/2021/08/IMG_4617-copy-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.taylorsvilletimes.com/2021/08/11/plane-comes-down-in-field/" rel="bookmark" title="Plane comes down in field">Plane comes down in field</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> August 11, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.taylorsvilletimes.com/2021/08/11/plane-comes-down-in-field/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> </div> </article> </div> <div class="fl-sidebar fl-sidebar-right fl-sidebar-display-always col-md-3" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"> <aside id="adrotate_widgets-2" class="fl-widget widget_adrotate_widgets"><div class="g g-1"><div class="g-dyn a-3 c-1"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Adams Funeral Home - Spotlight', 1.00, {'nonInteraction': 1});" href="http://www.adamsfunerals.com" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Adams Funeral Home - Spotlight', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2017/01/Adams-Funeral-BC-2017.jpg" /></a></div><div class="g-dyn a-18 c-2"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Jobs', 1.00, {'nonInteraction': 1});" href="http://www.hometownemploymentnetwork.com/default.aspx?affiliateid=1137" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Jobs', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2016/09/jobs.jpg" /></a></div><div class="g-dyn a-26 c-3"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Service Directory', 1.00, {'nonInteraction': 1});" href="https://www.taylorsvilletimes.com/business-service-directory/"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Service Directory', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2017/08/Service-Directory-BC-for-web-2017.jpg" /></a></div></div></aside><aside id="adrotate_widgets-3" class="fl-widget widget_adrotate_widgets"><div class="a-single a-10"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Breaking News Signup', 1.00, {'nonInteraction': 1});" href="https://www.taylorsvilletimes.com/breaking-news-signup/"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Breaking News Signup', 2.00, {'nonInteraction': 1});" src="https://www.taylorsvilletimes.com/wp-content/uploads/2016/10/breakingNewsHeader.png" /></a></div></aside><aside id="polls-widget-2" class="fl-widget widget_polls-widget"><h4 class="fl-widget-title">Online Poll</h4>Thank you for participating in our poll.<ul><li><a href="https://www.taylorsvilletimes.com/pollsarchive">Polls Archive</a></li></ul></aside><aside id="webads_displayads_widget-2" class="fl-widget widget_webads_displayads_widget"> <style>
                    #displayAds img {
                        width: 100%;
                        height: auto;
                    }

                                        #displayAdsWrapper {
                        height: 1500px;
                        overflow: hidden;
                    }
                    

                </style> <div id="displayAdsWrapper"> <div id="displayAds"> <ul id="displayAdsUL"> </ul> </div> </div>  <div id="displayAdDirLink"><h3><a href="https://www.taylorsvilletimes.com/1709/advertiser-directory">View All Advertisers</h3></div></aside> </div> </div> </div> </div> </div> <footer class="fl-page-footer-wrap" itemscope="itemscope" itemtype="http://schema.org/WPFooter"> <div class="fl-page-footer-widgets"> <div class="fl-page-footer-widgets-container container"> <div class="fl-page-footer-widgets-row row"> <div class="col-sm-4 col-md-4"><aside id="nav_menu-3" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">The Taylorsville Times</h4><div class="menu-footer-menu-1-container"><ul id="menu-footer-menu-1" class="menu"><li id="menu-item-228" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-228"><a href="https://www.taylorsvilletimes.com/">Home</a></li> <li id="menu-item-229" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-229"><a href="https://www.taylorsvilletimes.com/contact-us/">Contact Us</a></li> <li id="menu-item-24392" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24392"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=ebf2cc70-aaa6-40ab-ac88-1de546069d6d">The Taylorsville Times</a></li> <li id="menu-item-24391" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24391"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=4b944019-7f68-4c98-beee-fd6f2e06aaaa">The Bethlehem Star</a></li> <li id="menu-item-24390" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24390"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=fced17f6-97f1-4d30-9c1f-2b478c0f1936">125th Anniversary Edition</a></li> <li id="menu-item-231" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-231"><a target="_blank" rel="noopener noreferrer" href="http://1709.newstogo.us/editionviewer/default.aspx?Publication=ebf2cc70-aaa6-40ab-ac88-1de546069d6d&#038;view=subscribe">Subscribe</a></li> <li id="menu-item-23835" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23835"><a href="https://www.taylorsvilletimes.com/copyright/">Copyright</a></li> <li id="menu-item-23836" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23836"><a href="https://www.taylorsvilletimes.com/times-history/">Times&#8217; History</a></li> <li id="menu-item-23837" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23837"><a href="https://www.taylorsvilletimes.com/advertising-rates/">Advertising Rates</a></li> <li id="menu-item-23839" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23839"><a href="https://www.taylorsvilletimes.com/where-to-buy-the-times/">Where To Buy The Times</a></li> </ul></div></aside></div><div class="col-sm-4 col-md-4"><aside id="webads_syndicated_stories_menu_widget-2" class="fl-widget widget_webads_syndicated_stories_menu_widget"><h4 class="fl-widget-title">US &#038; World News</h4> <div><ul class="menu"> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/united-states/">US</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/sports/">Sports</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/entertainment/">Entertainment</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/technology/">Technology</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/political/">Politics</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/world/">World</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/business/">Business</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.taylorsvilletimes.com/syndicated_category/health/">Health</a></li> </ul></div> </aside></div><div class="col-sm-4 col-md-4"><aside id="nav_menu-5" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">Odds &#038; Ends</h4><div class="menu-footer-menu-3-container"><ul id="menu-footer-menu-3" class="menu"><li id="menu-item-216" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-216"><a href="https://www.taylorsvilletimes.com/crossword/">Crossword Puzzle</a></li> <li id="menu-item-217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-217"><a href="https://www.taylorsvilletimes.com/event-calendar/">Event Calendar</a></li> <li id="menu-item-1473" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1473"><a href="https://www.taylorsvilletimes.com/poll/">Online Poll</a></li> <li id="menu-item-218" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218"><a href="https://www.taylorsvilletimes.com/photos/">Photo Galleries</a></li> <li id="menu-item-23840" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23840"><a href="https://www.taylorsvilletimes.com/meet-us-on-social-media/">Meet us on social media</a></li> </ul></div></aside></div> </div> </div> </div><div class="fl-page-footer"> <div class="fl-page-footer-container container"> <div class="fl-page-footer-row row"> <div class="col-md-12 text-center clearfix"><div class="fl-page-footer-text fl-page-footer-text-1">This website is powered by <a href="http://www.websitesfornewspapers.com" target="_blank"><i><strong>WebsitesForNewspapers.com</strong></i></a></div></div> </div> </div> </div> </footer>            
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script></body></html>
<!--
Cached page generated by Borlabs Cache - more information https://borlabs.io/
Time to create cache: 4.14830995 sec
Time to load cache: 0.65469217
Cache file created on: 2021-08-18T22:06:41+00:00
Current time: 2021-08-19T00:43:04+00:00
-->